2011-10-07 |
Brian Fraser | Cast to signed before negating, to avoid compiler warnings |
blob | commitdiff |
2011-10-06 |
Brian Fraser | mro.(c|xs): Make warnings utf8-clean |
blob | commitdiff | diff to current |
2011-10-06 |
Father Chrysostomos | mro.c: Correct utf8 and bytes concatenation |
blob | commitdiff | diff to current |
2011-10-06 |
Brian Fraser | mro UTF8 cleanup. |
blob | commitdiff | diff to current |
2011-09-09 |
Father Chrysostomos | Correct mro.c typo added by 006d9e7b3 |
blob | commitdiff | diff to current |
2011-08-26 |
Father Chrysostomos | Correct mro_get_linear_isa’s docs |
blob | commitdiff | diff to current |
2011-05-18 |
Michael Witten | Clean: Actually use HvUSEDKEYS() instead of HvKEYS() |
blob | commitdiff | diff to current |
2011-04-16 |
Father Chrysostomos | Followup to 088225f/[perl #88132]: packages ending... |
blob | commitdiff | diff to current |
2011-01-07 |
Peter J. Acklam... | Fix typos (spelling errors) in Perl sources. |
blob | commitdiff | diff to current |
2010-12-01 |
Jerry D. Hedden | Fix uninit compiler warning in mro.c |
blob | commitdiff | diff to current |
2010-11-27 |
Father Chrysostomos | mro.c: Assert that the previous commit is correct |
blob | commitdiff | diff to current |
2010-11-27 |
Father Chrysostomos | Avoid a redundant check in mro.c |
blob | commitdiff | diff to current |
2010-11-27 |
Rafael Garcia-Suarez | Fix a warning (that spotted a potential mro bug that... |
blob | commitdiff | diff to current |
2010-11-25 |
Nicholas Clark | Use newSVpvs_flags() instead of sv_2mortal(newSVpvs()) |
blob | commitdiff | diff to current |
2010-11-24 |
Nicholas Clark | Convert xhv_name in struct xpvhv_aux to be a union... |
blob | commitdiff | diff to current |
2010-11-22 |
Father Chrysostomos | Remove redundant check |
blob | commitdiff | diff to current |
2010-11-22 |
Father Chrysostomos | mro_package_moved must act on all effective names |
blob | commitdiff | diff to current |
2010-11-21 |
Father Chrysostomos | Add flags param to hv_ename_* |
blob | commitdiff | diff to current |
2010-11-21 |
Father Chrysostomos | Eliminate the newname param from mro_package_moved |
blob | commitdiff | diff to current |
2010-11-17 |
Father Chrysostomos | Remove unnecessary check in mro_package_moved |
blob | commitdiff | diff to current |
2010-11-17 |
Father Chrysostomos | Don’t skip mro_package_moved if the parent stash is... |
blob | commitdiff | diff to current |
2010-11-13 |
Father Chrysostomos | mro_package_moved only needs one loop |
blob | commitdiff | diff to current |
2010-11-13 |
Father Chrysostomos | Macro for freeing meta->mro_linear_* |
blob | commitdiff | diff to current |
2010-11-13 |
Father Chrysostomos | Remove redundant call to mro_get_linear_isa |
blob | commitdiff | diff to current |
2010-11-13 |
Father Chrysostomos | Update isarev when clobbered class has subsubclasses |
blob | commitdiff | diff to current |
2010-11-12 |
Father Chrysostomos | mro_isa_changed_in3 is no longer necessary |
blob | commitdiff | diff to current |
2010-11-12 |
Father Chrysostomos | Fix package assignment with nested aliased packages |
blob | commitdiff | diff to current |
2010-11-11 |
Father Chrysostomos | Correct comment in mro_isa_changed_in |
blob | commitdiff | diff to current |
2010-11-11 |
Father Chrysostomos | Fix memory leaks in mro_package_moved |
blob | commitdiff | diff to current |
2010-11-09 |
Father Chrysostomos | [perl #75176] Symbol::delete_package does not free... |
blob | commitdiff | diff to current |
2010-10-31 |
Father Chrysostomos | [perl #77358] ISA warnings after aliasing packages |
blob | commitdiff | diff to current |
2010-10-30 |
Father Chrysostomos | Set stash names before calling mro_isa_changed_in3 |
blob | commitdiff | diff to current |
2010-10-30 |
Father Chrysostomos | Comment typo |
blob | commitdiff | diff to current |
2010-10-30 |
Father Chrysostomos | Move the meta->isa code from UNIVERSAL::isa to mro_get_... |
blob | commitdiff | diff to current |
2010-10-30 |
Father Chrysostomos | Switch the core MRO code over to HvENAME |
blob | commitdiff | diff to current |
2010-10-27 |
Father Chrysostomos | Renaming of stashes should not be visible from Perl |
blob | commitdiff | diff to current |
2010-10-25 |
Father Chrysostomos | Rename stashes when they move around |
blob | commitdiff | diff to current |
2010-10-24 |
Father Chrysostomos | Make mro_package_moved use a mortal in case mro_isa_cha... |
blob | commitdiff | diff to current |
2010-10-21 |
Father Chrysostomos | Fix a nested package deletion bug |
blob | commitdiff | diff to current |
2010-10-13 |
Father Chrysostomos | [perl #78362] Make mro_package_moved check for recursion |
blob | commitdiff | diff to current |
2010-10-12 |
Father Chrysostomos | Reset isa caches on nonexistent substashes when stash... |
blob | commitdiff | diff to current |
2010-10-11 |
Father Chrysostomos | Allow mro_isa_changed_in to be called on nonexistent... |
blob | commitdiff | diff to current |
2010-10-10 |
Father Chrysostomos | Reset isa on stash manipulation |
blob | commitdiff | diff to current |
2010-05-24 |
Nicholas Clark | Convert Perl_sv_dup_inc() from a macro to a real function. |
blob | commitdiff | diff to current |
2009-08-21 |
Jerry D. Hedden | Fix build warning in mro.c |
blob | commitdiff | diff to current |
2009-08-20 |
Nicholas Clark | Optimise S_mro_get_linear_isa_dfs() when dealing with... |
blob | commitdiff | diff to current |
2009-07-25 |
Nicholas Clark | When resetting our children, wipe out the isa cache... |
blob | commitdiff | diff to current |
2009-01-03 |
Nicholas Clark | Following change 34356, which decoupled get_isa_hash... |
blob | commitdiff | diff to current |
2008-12-28 |
Nicholas Clark | Add casts to gain C++ compatibility, as spotted by... |
blob | commitdiff | diff to current |
2008-12-27 |
Nicholas Clark | Move all mro:: XS functions from mro.c to ext/mro/mro... |
blob | commitdiff | diff to current |
2008-12-27 |
Nicholas Clark | In struct mro_meta, rename mro_linear_dfs to mro_linear... |
blob | commitdiff | diff to current |
2008-12-27 |
Nicholas Clark | In struct mro_meta, rename mro_linear_c3 to mro_linear_... |
blob | commitdiff | diff to current |
2008-12-27 |
Nicholas Clark | Break out the set-the-MRO logic from the XS_mro_set_mro... |
blob | commitdiff | diff to current |
2008-12-27 |
Nicholas Clark | Optimisation of the use of the meta structure - don... |
blob | commitdiff | diff to current |
2008-12-27 |
Nicholas Clark | Proper pluggable Method Resolution Orders. 'c3' is... |
blob | commitdiff | diff to current |
2008-12-27 |
Nicholas Clark | Add Perl_mro_register() to register Method Resolution... |
blob | commitdiff | diff to current |
2008-12-27 |
Nicholas Clark | Add MRO_GET_PRIVATE_DATA() to use the cached mro privat... |
blob | commitdiff | diff to current |
2008-12-27 |
Nicholas Clark | Repurpose struct mro_meta to allow it to store cached... |
blob | commitdiff | diff to current |
2008-11-27 |
Nicholas Clark | S_mro_get_linear_isa_*() should have an *un*signed... |
blob | commitdiff | diff to current |
2008-11-02 |
Tom Christiansen | PATCH: Large omnibus patch to clean up the JRRT quotes |
blob | commitdiff | diff to current |
2008-10-30 |
Nicholas Clark | Eliminate (SV *) casts from the rest of *.c, picking... |
blob | commitdiff | diff to current |
2008-10-29 |
Nicholas Clark | Eliminate (AV *) casts in *.c. |
blob | commitdiff | diff to current |
2008-10-28 |
Nicholas Clark | Every remaining (HV *) cast in *.c |
blob | commitdiff | diff to current |
2008-10-25 |
Nicholas Clark | Update copyright years. |
blob | commitdiff | diff to current |
2008-09-12 |
Nicholas Clark | In S_mro_get_linear_isa_dfs(), add void casts to silenc... |
blob | commitdiff | diff to current |
2008-09-12 |
Nicholas Clark | Build the isa cache from any linear ISA, rather than... |
blob | commitdiff | diff to current |
2008-09-12 |
Nicholas Clark | Need to free the isa lookup hash before rebuilding it. |
blob | commitdiff | diff to current |
2008-09-12 |
Nicholas Clark | Create a direct lookup hash for ->isa() lookup, by... |
blob | commitdiff | diff to current |
2008-08-22 |
Nicholas Clark | In S_mro_get_linear_isa_dfs(), save copying by making... |
blob | commitdiff | diff to current |
2008-08-22 |
Nicholas Clark | In S_mro_get_linear_isa_dfs(), hv_exists_ent() followed... |
blob | commitdiff | diff to current |
2008-05-21 |
Nicholas Clark | Add Perl_croak_xs_usage(), which reduces a lot of expli... |
blob | commitdiff | diff to current |
2008-02-25 |
ilmari@vesla.ilmar... | Avoid a segfault case in MRO code, based on : |
blob | commitdiff | diff to current |
2008-02-12 |
Nicholas Clark | assert() that every NN argument is not NULL. Otherwise... |
blob | commitdiff | diff to current |
2008-01-04 |
Marcus Holland-Moritz | Add macros mPUSHs() and mXPUSHs() for pushing SVs on... |
blob | commitdiff | diff to current |
2008-01-03 |
Nicholas Clark | Extend newSVpvn_flags() to also call sv_2mortal() if... |
blob | commitdiff | diff to current |
2008-01-03 |
Nicholas Clark | We can now sv_upgrade(sv, SVt_PVHV), so do so, to simpl... |
blob | commitdiff | diff to current |
2007-10-22 |
Nicholas Clark | hv_iterkeysv() actually creates a mortal SV for every... |
blob | commitdiff | diff to current |
2007-10-22 |
Nicholas Clark | In Perl_mro_isa_changed_in(), no need to call an RVALUE... |
blob | commitdiff | diff to current |
2007-10-22 |
Nicholas Clark | S_mro_get_linear_isa_c3() doesn't need to call hv_fetch... |
blob | commitdiff | diff to current |
2007-10-18 |
Nicholas Clark | By using the HEK that holds the stash name in S_mro_get... |
blob | commitdiff | diff to current |
2007-10-12 |
Nicholas Clark | Remove some strlen()s and replace one strlcpy() with... |
blob | commitdiff | diff to current |
2007-09-28 |
Rafael Garcia-Suarez | Remove unneeded cast |
blob | commitdiff | diff to current |
2007-09-26 |
Nicholas Clark | Change 31977 introduced a bug (failing to set the retur... |
blob | commitdiff | diff to current |
2007-09-26 |
Nicholas Clark | Change the way of determining the MRO algorithm used... |
blob | commitdiff | diff to current |
2007-09-21 |
Rafael Garcia-Suarez | Silence a load of "value computed is not used" warnings |
blob | commitdiff | diff to current |
2007-09-20 |
Nicholas Clark | SVs know their length, so avoid 2 calls to strlen(). |
blob | commitdiff | diff to current |
2007-09-12 |
Nicholas Clark | mro_get_linear_isa_dfs and mro_get_linear_isa_c3 can... |
blob | commitdiff | diff to current |
2007-07-01 |
Nicholas Clark | Restore a comment from 30501 unintentionally deleted... |
blob | commitdiff | diff to current |
2007-07-01 |
Nicholas Clark | Avoid copying the AV in Perl_mro_get_linear_isa_dfs() |
blob | commitdiff | diff to current |
2007-06-29 |
Rafael Garcia-Suarez | Revert change #31489. |
blob | commitdiff | diff to current |
2007-06-29 |
Brandon Black | Re: valgrind findings |
blob | commitdiff | diff to current |
2007-06-28 |
Brandon Black | Re: [perl #43357] *DESTROY = sub {} at runtime |
blob | commitdiff | diff to current |
2007-06-13 |
Brandon Black | yet another mro.c patch |
blob | commitdiff | diff to current |
2007-06-07 |
Jerry D. Hedden | Silence compiler warnings |
blob | commitdiff | diff to current |
2007-06-04 |
Brandon Black | another mro patch |
blob | commitdiff | diff to current |
2007-05-30 |
Brandon Black | Re: HvMROMETA |
blob | commitdiff | diff to current |
2007-05-19 |
Craig A. Berry | Various mro updates from Brandon Black. References: |
blob | commitdiff | diff to current |
2007-05-09 |
Brandon Black | Re: mro c3 infinite recursion problem. Attemp to free... |
blob | commitdiff | diff to current |
2007-05-08 |
Andy Lester | more consting |
blob | commitdiff | diff to current |
2007-04-30 |
Brandon Black | Re: mro status, etc |
blob | commitdiff | diff to current |
next |