This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
set api_version to 5.5.0 (binary compatibility needs to get tested
authorGurusamy Sarathy <gsar@cpan.org>
Sun, 23 Jan 2000 10:14:46 +0000 (10:14 +0000)
committerGurusamy Sarathy <gsar@cpan.org>
Sun, 23 Jan 2000 10:14:46 +0000 (10:14 +0000)
more widely)

p4raw-id: //depot/perl@4858

patchlevel.h

index 9670081..8d9d284 100644 (file)
    compatibility to run XS code built with the older version).
    Normally this should not change across maintenance releases.
 
+   Note that this only refers to an out-of-the-box build.  Many non-default
+   options such as usemultiplicity tend to break binary compatibility
+   more often.
+
    This is used by Configure et al to figure out 
    PERL_INC_VERSION_LIST, which lists version libraries
    to include in @INC.  See INSTALL for how this works.
 */
 #define PERL_API_REVISION      5       /* Adjust manually as needed.  */
 #define PERL_API_VERSION       5       /* Adjust manually as needed.  */
-#define PERL_API_SUBVERSION    640     /* Adjust manually as needed.  */
+#define PERL_API_SUBVERSION    0       /* Adjust manually as needed.  */
 /*
    XXX Note:  The selection of non-default Configure options, such
    as -Duselonglong may invalidate these settings.  Currently, Configure