This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
The _POSIX_OPEN_MAX values are allowed *minimums*,
authorJarkko Hietaniemi <jhi@iki.fi>
Sat, 2 Mar 2002 19:52:58 +0000 (19:52 +0000)
committerJarkko Hietaniemi <jhi@iki.fi>
Sat, 2 Mar 2002 19:52:58 +0000 (19:52 +0000)
higher is okay.

p4raw-id: //depot/perl@14950

ext/POSIX/t/posix.t

index d73dae0..a4d3792 100644 (file)
@@ -92,7 +92,7 @@ SKIP: {
     skip("_POSIX_OPEN_MAX is inaccurate on MPE", 1) if $Is_MPE;
     skip("_POSIX_OPEN_MAX undefined ($fds[1])",  1) unless &_POSIX_OPEN_MAX;
 
-    ok( &_POSIX_OPEN_MAX == 16 || &_POSIX_OPEN_MAX == 20, "The two allowed values according to susv2 and susv3" );
+    ok( &_POSIX_OPEN_MAX >= 16, "The minimum allowed values according to susv2" );
 
 }