This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Have win32/makefile.mk default to gcc, and update docs
authorSteve Hay <SteveHay@planit.com>
Thu, 3 Jun 2004 15:46:17 +0000 (16:46 +0100)
committerRafael Garcia-Suarez <rgarciasuarez@gmail.com>
Thu, 3 Jun 2004 15:19:52 +0000 (15:19 +0000)
Message-ID: <40BF39B9.3060207@uk.radan.com>

p4raw-id: //depot/perl@22901

README.win32
win32/makefile.mk

index ffec4b7..b9ab612 100644 (file)
@@ -43,11 +43,10 @@ following compilers on the Intel x86 architecture:
 
       Borland C++              version 5.02 or later
       Microsoft Visual C++     version 4.2 or later
-      Mingw32 with GCC         version 2.95.2 or better
+      MinGW with gcc           gcc version 2.95.2 or later
 
-The last of these is a high quality freeware compiler.  Support
-for it is still experimental.  (Older versions of GCC are known
-not to work.)
+The last of these is a high quality freeware compiler.  Use version
+3.2.x or later for the best results with this compiler.
 
 This port can also be built on the Intel IA64 using:
 
@@ -138,24 +137,19 @@ The nmake that comes with the Platform SDK will suffice for building
 Perl.  Make sure you are building within one of the "Build Environment"
 shells available after you install the Platform SDK from the Start Menu.
 
-=item MinGW32 with gcc
+=item MinGW release 3 with gcc
 
-The latest release of MinGW (at the time of writing) is 2.0.0, which comes 
-with gcc-3.2, and can be downloaded here:
+The latest release of MinGW at the time of writing is 3.1.0, which comes 
+with gcc-3.2.3, and can be downloaded here:
 
-    http://sourceforge.net/projects/mingw
+    http://www.mingw.org/
 
-Perl compiles with earlier releases of gcc (2.95 and up) that can be
-downloaded from the same place. If you use gcc-3.2, comment out the
-line:
-
-    USE_GCC_V3_2       *= define
-
-in win32\makefile.mk
+Perl also compiles with earlier releases of gcc (2.95.2 and up).  See below
+for notes about using earlier versions of MinGW/gcc.
 
 You also need dmake.  See L</"Make"> above on how to get it.
 
-=item MinGW release 1
+=item MinGW release 1 with gcc
 
 The MinGW-1.1 bundle comes with gcc-2.95.3.
 
index fd702a9..c43a881 100644 (file)
@@ -89,14 +89,11 @@ USE_LARGE_FILES *= define
 # Visual C++ > 2.x and < 6.x
 #CCTYPE                *= MSVC
 # Visual C++ >= 6.x
-CCTYPE         *= MSVC60
+#CCTYPE                *= MSVC60
 # Borland 5.02 or later
 #CCTYPE                *= BORLAND
-# mingw32+gcc-2.95.2 or better
-#CCTYPE                *= GCC
-# Uncomment this if you are using the latest MinGW release (2.0.0)
-# with gcc3.2
-#USE_GCC_V3_2  *= define
+# MinGW with gcc-2.95.2 or later
+CCTYPE         *= GCC
 
 #
 # uncomment this if your Borland compiler is older than v5.4.
@@ -379,9 +376,6 @@ LINK_FLAGS  += -L"$(CCLIBDIR)\Release"
 
 CC             = gcc
 LINK32         = g++
-.IF "$(USE_GCC_V3_2)" == "define"
-LINK32         = g++
-.END
 LIB32          = ar rc
 IMPLIB         = dlltool
 RSC            = windres