This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Patch installperl to be long double-aware.
authorSpider Boardman <spider@orb.nashua.nh.us>
Fri, 25 Aug 2000 18:15:23 +0000 (14:15 -0400)
committerJarkko Hietaniemi <jhi@iki.fi>
Fri, 25 Aug 2000 23:01:20 +0000 (23:01 +0000)
Subject: Re: [PATCH] [ID 20000825.019] Not OK: perl v5.7.0 +SUIDMAIL +DEVEL6820 on alpha-dec_osf 5.1 (UNINSTALLED)
Message-Id: <200008252215.SAA28740@leggy.zk3.dec.com>

p4raw-id: //depot/perl@6826

installperl

index eb2a31e..b50c745 100755 (executable)
@@ -113,9 +113,10 @@ find(sub {
 
 # print "[$_]\n" for sort keys %archpms;
 
+my $perlver = sprintf "%8.6f",$];
 my $ver = $Config{version};
-my $release = substr($],0,3);   # Not used presently.
-my $patchlevel = substr($],3,2);
+my $release = substr($perlver,0,3);   # Not used presently.
+my $patchlevel = substr($perlver,3,2);
 die "Patchlevel of perl ($patchlevel)",
     "and patchlevel of config.sh ($Config{'PERL_VERSION'}) don't match\n"
        if $patchlevel != $Config{'PERL_VERSION'};