This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Temporary bump PPPort to 3.54 before next release
authorNicolas R <atoomic@cpan.org>
Fri, 21 Jun 2019 20:46:27 +0000 (16:46 -0400)
committerNicolas R <atoomic@cpan.org>
Fri, 21 Jun 2019 21:11:01 +0000 (17:11 -0400)
This is making porting/cmp_version.t happy for now.
We plan to release Devel::PPPort over the next days/weeks
and this would be required before the next release.

Note that previous Perl version was release without
releasing Devel::PPPort. We probably want to release
a 3.53 version matching it, followed by a 3.54 one.

dist/Devel-PPPort/PPPort_pm.PL
dist/Module-CoreList/lib/Module/CoreList.pm
pod/perl5311delta.pod

index 05525ed..a78d402 100644 (file)
@@ -551,7 +551,7 @@ package Devel::PPPort;
 use strict;
 use vars qw($VERSION $data);
 
-$VERSION = '3.53';
+$VERSION = '3.54';
 
 sub _init_data
 {
index 1a92e40..5af9c29 100644 (file)
@@ -5760,7 +5760,7 @@ for my $version ( sort { $a <=> $b } keys %released ) {
             'B::Deparse'            => '1.05',
             'Benchmark'             => '1.13',
             'CGI'                   => '3.54',
-            'CGI::Util'             => '3.53',
+            'CGI::Util'             => '3.54',
             'CPAN::Meta'            => '2.110930',
             'CPAN::Meta::Converter' => '2.110930',
             'CPAN::Meta::Feature'   => '2.110930',
@@ -10821,7 +10821,7 @@ for my $version ( sort { $a <=> $b } keys %released ) {
             'ExtUtils::ParseXS::Eval'=> '3.27',
             'ExtUtils::ParseXS::Utilities'=> '3.27',
             'ExtUtils::testlib'     => '7.04',
-            'File::Spec'            => '3.53',
+            'File::Spec'            => '3.54',
             'File::Spec::Cygwin'    => '3.54',
             'File::Spec::Epoc'      => '3.54',
             'File::Spec::Functions' => '3.54',
@@ -16353,7 +16353,7 @@ for my $version ( sort { $a <=> $b } keys %released ) {
             'Compress::Zlib'        => '2.086',
             'Config'                => '5.031001',
             'DB_File'               => '1.852',
-            'Devel::PPPort'         => '3.53',
+            'Devel::PPPort'         => '3.54',
             'ExtUtils::CBuilder'    => '0.280232',
             'ExtUtils::Command'     => '7.36',
             'ExtUtils::Command::MM' => '7.36',
index eb29fb6..0249128 100644 (file)
@@ -58,7 +58,7 @@ L<DB_File> has been upgraded from version 1.843 to 1.852.
 
 =item *
 
-L<Devel::PPPort> has been upgraded from version 3.52 to 3.53.
+L<Devel::PPPort> has been upgraded from version 3.52 to 3.54.
 
 =item *