This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
make Config.pm report sane errors with older perls
authorGurusamy Sarathy <gsar@cpan.org>
Fri, 17 Mar 2000 17:00:05 +0000 (17:00 +0000)
committerGurusamy Sarathy <gsar@cpan.org>
Fri, 17 Mar 2000 17:00:05 +0000 (17:00 +0000)
p4raw-id: //depot/perl@5787

configpm

index 19d0d71..c64af8a 100755 (executable)
--- a/configpm
+++ b/configpm
@@ -38,6 +38,9 @@ sub import {
 }
 
 ENDOFBEG_NOQ
+die "Perl lib version ($myver) doesn't match executable version (\$])"
+    unless \$^V;
+
 \$^V eq $myver
   or die "Perl lib version ($myver) doesn't match executable version (" .
     (sprintf "v%vd",\$^V) . ")";