This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Update perlfaq to CPAN version 5.20200523
authorKaren Etheridge <ether@cpan.org>
Fri, 22 May 2020 03:30:45 +0000 (20:30 -0700)
committerKarl Williamson <khw@cpan.org>
Fri, 22 May 2020 12:26:59 +0000 (06:26 -0600)
  [DELTA]

5.20200523  2020-05-22 03:28:54Z
  * switch perlbug references to GitHub issue tracker (PR##87, Dan Book)

5.20200522  2020-05-22 02:24:31Z
  * updated perlfaq1 entry on Raku (PR##86, Dan Book)

13 files changed:
Porting/Maintainers.pl
cpan/perlfaq/lib/perlfaq.pm
cpan/perlfaq/lib/perlfaq.pod
cpan/perlfaq/lib/perlfaq1.pod
cpan/perlfaq/lib/perlfaq2.pod
cpan/perlfaq/lib/perlfaq3.pod
cpan/perlfaq/lib/perlfaq4.pod
cpan/perlfaq/lib/perlfaq5.pod
cpan/perlfaq/lib/perlfaq6.pod
cpan/perlfaq/lib/perlfaq7.pod
cpan/perlfaq/lib/perlfaq8.pod
cpan/perlfaq/lib/perlfaq9.pod
cpan/perlfaq/lib/perlglossary.pod

index 14f5e28..41c2e2c 100755 (executable)
@@ -877,7 +877,7 @@ use File::Glob qw(:case);
     },
 
     'perlfaq' => {
-        'DISTRIBUTION' => 'ETHER/perlfaq-5.20200125.tar.gz',
+        'DISTRIBUTION' => 'ETHER/perlfaq-5.20200523.tar.gz',
         'FILES'        => q[cpan/perlfaq],
         'EXCLUDED'     => [ qr/^inc/, qr/^xt/, qr{^t/00-} ],
     },
index 5f515ca..c8016cf 100644 (file)
@@ -2,6 +2,6 @@ use strict;
 use warnings;
 package perlfaq;
 
-our $VERSION = '5.20200125';
+our $VERSION = '5.20200523';
 
 1;
index ee5c25f..3b7345a 100644 (file)
@@ -4,7 +4,7 @@ perlfaq - Frequently asked questions about Perl
 
 =head1 VERSION
 
-version 5.20200125
+version 5.20200523
 
 =head1 DESCRIPTION
 
@@ -89,11 +89,11 @@ Which version of Perl should I use?
 
 =item *
 
-What are Perl 4, Perl 5, or Perl 6?
+What are Perl 4, Perl 5, or Raku (Perl 6)?
 
 =item *
 
-What is Perl 6?
+What is Raku (Perl 6)?
 
 =item *
 
index 3ee86e2..0ec9f16 100644 (file)
@@ -4,7 +4,7 @@ perlfaq1 - General Questions About Perl
 
 =head1 VERSION
 
-version 5.20200125
+version 5.20200523
 
 =head1 DESCRIPTION
 
@@ -123,11 +123,11 @@ current stable release of Perl.
 
 =back
 
-=head2 What are Perl 4, Perl 5, or Perl 6?
+=head2 What are Perl 4, Perl 5, or Raku (Perl 6)?
 
-In short, Perl 4 is the parent to both Perl 5 and Perl 6. Perl 5 is the older
-sibling, and though they are different languages, someone who knows one will
-spot many similarities in the other.
+In short, Perl 4 is the parent to both Perl 5 and Raku (formerly known as
+Perl 6). Perl 5 is the older sibling, and though they are different languages,
+someone who knows one will spot many similarities in the other.
 
 The number after Perl (i.e. the 5 after Perl 5) is the major release
 of the perl interpreter as well as the version of the language. Each
@@ -138,31 +138,30 @@ The current major release of Perl is Perl 5, first released in
 1994. It can run scripts from the previous major release, Perl 4
 (March 1991), but has significant differences.
 
-Perl 6 is a reinvention of Perl, it is a language in the same lineage but
-not compatible. The two are complementary, not mutually exclusive. Perl 6 is
-not meant to replace Perl 5, and vice versa. See L</"What is Perl 6?"> below
-to find out more.
+Raku is a reinvention of Perl, a language in the same lineage but
+not compatible. The two are complementary, not mutually exclusive. Raku is
+not meant to replace Perl, and vice versa. See L</"What is Raku (Perl 6)?">
+below to find out more.
 
 See L<perlhist> for a history of Perl revisions.
 
-=head2 What is Perl 6?
+=head2 What is Raku (Perl 6)?
 
-Perl 6 was I<originally> described as the community's rewrite of Perl 5,
-however as the language evolved, it became clear that it is a separate
-language, but in the same language family as Perl 5.
+Raku (formerly known as Perl 6) was I<originally> described as the community's
+rewrite of Perl, however as the language evolved, it became clear that it is
+a separate language, but in the same language family as Perl.
 
-Perl 6 is not intended primarily as a replacement for Perl 5, but as its
-own thing - and libraries exist to allow you to call Perl 5 code from Perl
-programs and vice versa.
+Raku is not intended primarily as a replacement for Perl, but as its
+own thing - and libraries exist to allow you to call Perl code from Raku
+programs and vice versa.
 
-Contrary to popular belief, Perl 6 and Perl 5 peacefully coexist with one
-another. Perl 6 has proven to be a fascinating source of ideas for those
-using Perl (the L<Moose> object system is a well-known example). There is
+Contrary to popular belief, Raku and Perl peacefully coexist with one
+another. Raku has proven to be a fascinating source of ideas for those
+using Perl (the L<Moose> object system is a well-known example). There is
 overlap in the communities, and this overlap fosters the tradition of sharing
 and borrowing that have been instrumental to Perl's success.
 
-If you want to learn more about Perl 6 read the Perl 6 developers
-page at L<http://www.perl6.org/> and get involved.
+For more about Raku see L<https://www.raku.org/>.
 
 "We're really serious about reinventing everything that needs reinventing."
 --Larry Wall
index 372cc84..447ad08 100644 (file)
@@ -4,7 +4,7 @@ perlfaq2 - Obtaining and Learning about Perl
 
 =head1 VERSION
 
-version 5.20200125
+version 5.20200523
 
 =head1 DESCRIPTION
 
@@ -213,10 +213,9 @@ First, ensure that you've found an actual bug. Second, ensure you've
 found an actual bug.
 
 If you've found a bug with the perl interpreter or one of the modules
-in the standard library (those that come with Perl), you can use the
-L<perlbug> utility that comes with Perl (>= 5.004). It collects
-information about your installation to include with your message, then
-sends the message to the right place.
+in the standard library (those that come with Perl), you can submit a
+bug report to the GitHub issue tracker at
+L<https://github.com/Perl/perl5/issues>.
 
 To determine if a module came with your version of Perl, you can
 install and use the L<Module::CoreList> module. It has the information
index 0051cc8..481c3c9 100644 (file)
@@ -4,7 +4,7 @@ perlfaq3 - Programming Tools
 
 =head1 VERSION
 
-version 5.20200125
+version 5.20200523
 
 =head1 DESCRIPTION
 
@@ -1098,7 +1098,8 @@ XS support files.
 
 Download the ExtUtils::Embed kit from CPAN and run `make test'. If
 the tests pass, read the pods again and again and again. If they
-fail, see L<perlbug> and send a bug report with the output of
+fail, submit a bug report to L<https://github.com/Perl/perl5/issues>
+with the output of
 C<make test TEST_VERBOSE=1> along with C<perl -V>.
 
 =head2 When I tried to run my script, I got this message. What does it mean?
index ba5c7e5..1a20aba 100644 (file)
@@ -4,7 +4,7 @@ perlfaq4 - Data Manipulation
 
 =head1 VERSION
 
-version 5.20200125
+version 5.20200523
 
 =head1 DESCRIPTION
 
index e1829ef..a7fc0ea 100644 (file)
@@ -4,7 +4,7 @@ perlfaq5 - Files and Formats
 
 =head1 VERSION
 
-version 5.20200125
+version 5.20200523
 
 =head1 DESCRIPTION
 
index b1cd79f..9a45f0e 100644 (file)
@@ -4,7 +4,7 @@ perlfaq6 - Regular Expressions
 
 =head1 VERSION
 
-version 5.20200125
+version 5.20200523
 
 =head1 DESCRIPTION
 
index 47801a3..a69e053 100644 (file)
@@ -4,7 +4,7 @@ perlfaq7 - General Perl Language Issues
 
 =head1 VERSION
 
-version 5.20200125
+version 5.20200523
 
 =head1 DESCRIPTION
 
index baf932f..8ee088a 100644 (file)
@@ -4,7 +4,7 @@ perlfaq8 - System Interaction
 
 =head1 VERSION
 
-version 5.20200125
+version 5.20200523
 
 =head1 DESCRIPTION
 
index 09e4235..15ca2d0 100644 (file)
@@ -4,7 +4,7 @@ perlfaq9 - Web, Email and Networking
 
 =head1 VERSION
 
-version 5.20200125
+version 5.20200523
 
 =head1 DESCRIPTION
 
index 3bca207..2e7eeda 100644 (file)
@@ -7,7 +7,7 @@ perlglossary - Perl Glossary
 
 =head1 VERSION
 
-version 5.20200125
+version 5.20200523
 
 =head1 DESCRIPTION