This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Updated CPANPLUS to cpan version 0.89_04
authorChris Williams <chris@bingosnet.co.uk>
Fri, 23 Oct 2009 11:33:09 +0000 (12:33 +0100)
committerChris Williams <chris@bingosnet.co.uk>
Fri, 23 Oct 2009 11:33:09 +0000 (12:33 +0100)
  Changes for 0.89_04     Fri Oct 23 11:12:57 2009
  ================================================
  * Added deprecated dual-life module support which
    requires newer versions of Module::CoreList and
    Module::Load::Conditional

Porting/Maintainers.pl
cpan/CPANPLUS/lib/CPANPLUS.pm
cpan/CPANPLUS/lib/CPANPLUS/Internals.pm
cpan/CPANPLUS/lib/CPANPLUS/Module.pm
cpan/CPANPLUS/lib/CPANPLUS/Selfupdate.pm
cpan/CPANPLUS/lib/CPANPLUS/Shell/Default.pm

index 143dfde..96a0a30 100755 (executable)
@@ -423,7 +423,7 @@ use File::Glob qw(:case);
     'CPANPLUS' =>
        {
        'MAINTAINER'    => 'kane',
-       'DISTRIBUTION'  => 'BINGOS/CPANPLUS-0.89_03.tar.gz',
+       'DISTRIBUTION'  => 'BINGOS/CPANPLUS-0.89_04.tar.gz',
        'FILES'         => q[cpan/CPANPLUS],
        'EXCLUDED'      => [ qr{^inc/},
                             qr{^t/dummy-.*\.hidden$},
index b0bc973..20f5f8a 100644 (file)
@@ -13,7 +13,7 @@ BEGIN {
     use vars        qw( @EXPORT @ISA $VERSION );
     @EXPORT     =   qw( shell fetch get install );
     @ISA        =   qw( Exporter );
-    $VERSION = "0.89_03";     #have to hardcode or cpan.org gets unhappy
+    $VERSION = "0.89_04";     #have to hardcode or cpan.org gets unhappy
 }
 
 ### purely for backward compatibility, so we can call it from the commandline:
index 60af0a9..75c7f95 100644 (file)
@@ -42,7 +42,7 @@ use vars qw[@ISA $VERSION];
             CPANPLUS::Internals::Report
         ];
 
-$VERSION = "0.89_03";
+$VERSION = "0.89_04";
 
 =pod
 
index 5f7cec0..9e4b67e 100644 (file)
@@ -1274,6 +1274,8 @@ Returns a boolean indicating if this module is uptodate or not.
             ### that may contain some of our sneakily loaded modules
             ### that aren't installed as such. -- kane
             local $Module::Load::Conditional::CHECK_INC_HASH = 0;
+            ### this should all that is required for deprecated core modules
+            local $Module::Load::Conditional::DEPRECATED = 1;
             my $href = check_install(
                             module  => $self->module,
                             version => $self->version,
index 1346de8..48f918c 100644 (file)
@@ -46,7 +46,7 @@ CPANPLUS::Selfupdate
             'Locale::Maketext::Simple'  => '0.01',
             'Log::Message'              => '0.01',
             'Module::Load'              => '0.10',
-            'Module::Load::Conditional' => '0.28', # returns dir for loaded
+            'Module::Load::Conditional' => '0.31_01', # returns dir for loaded
                                                    # modules
             'version'                   => '0.73', # needed for M::L::C
                                                    # addresses #24630 and 
@@ -62,7 +62,7 @@ CPANPLUS::Selfupdate
             'Archive::Tar'              => '1.23',
             'IO::Zlib'                  => '1.04', # needed for Archive::Tar
             'Object::Accessor'          => '0.34', # mk_aliases support
-            'Module::CoreList'          => '2.09',
+            'Module::CoreList'          => '2.22', # deprecated core modules
             'Module::Pluggable'         => '2.4',
             'Module::Loaded'            => '0.01',
             'Parse::CPAN::Meta'         => '0.02', # config_requires support
@@ -85,7 +85,7 @@ CPANPLUS::Selfupdate
             ],            
             cpantest        => [
                 { 'Test::Reporter'  => '1.34',
-                  'YAML::Tiny'      => '0.0'
+                  'Parse::CPAN::Meta' => '0.0'
                 },
                 sub { 
                     my $cb = shift;
index a83f57a..5384b6a 100644 (file)
@@ -26,7 +26,7 @@ local $Data::Dumper::Indent     = 1; # for dumpering from !
 BEGIN {
     use vars        qw[ $VERSION @ISA ];
     @ISA        =   qw[ CPANPLUS::Shell::_Base::ReadLine ];
-    $VERSION = "0.89_03";
+    $VERSION = "0.89_04";
 }
 
 load CPANPLUS::Shell;