This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Perl blead on AIX - fail: t/porting/test_bootstrap
authorRainer Tammer <tammer@tammer.net>
Mon, 18 Jan 2010 10:43:07 +0000 (11:43 +0100)
committerH.Merijn Brand <h.m.brand@xs4all.nl>
Mon, 18 Jan 2010 12:15:32 +0000 (13:15 +0100)
Hello,

Nicholas Clark wrote:
> On Mon, Jan 18, 2010 at 11:33:07AM +0100, Rainer Tammer wrote:
>
>> Hello,
>> the 32 bit blead build looks quite good on AIX:
>>
>> A threaded, shared 32 bit build only produced one error:
>>
> Thanks for continuing to look out for AIX.
>
>
No problem ...
>> Is this a know error ??
>>
> Yes, but I believe that I committed a change to fix it about 30 minutes ago.
>
>
OK,
I try this fix.

I have also a fix for the GDBM problem.
Now GDBM is only disabled if the "problem" headers are installed,
e.g. if the gdbm rpm < 1.8.3-5 is installed.

I have attached the patch for this.

> Nicholas Clark
>
>
>
Bye
  Rainer

From 4755db7f86c38d3c2b69c668c5747368e98c3eae Mon Sep 17 00:00:00 2001
From: Rainer Tammer <tammer@tammer.net>
Date: Mon, 18 Jan 2010 11:40:27 +0100
Subject: [PATCH] Enabld GDBM on AIX if possible

Signed-off-by: H.Merijn Brand <h.m.brand@xs4all.nl>
README.aix
hints/aix.sh

index 62d574e..999d9ad 100644 (file)
@@ -60,10 +60,13 @@ development team.
 
 =head2 Incompatibility with AIX Toolbox lib gdbm
 
-If the AIX Toolbox version of lib gdbm 1.8.x is installed on the
-system then Perl will not work. This library contains a defect version
-of the dbm_store() function. The lib gdbm will be automatically removed
-from the wanted libraries.
+If the AIX Toolbox version of lib gdbm < 1.8.3-5 is installed on your
+system then Perl will not work. This library contains the header files
+/opt/freeware/include/gdbm/dbm.h|ndbm.h which conflict with the AIX
+system versions. The lib gdbm will be automatically removed from the
+wanted libraries if the presence of one of these two header files is
+detected. If you want to bild Perl with GDBM support then please install
+at leas gdbm-devel-1.8.3-5 (or higher).
 
 =head2 Perl 5.10 was successfully compiled and tested on:
 
@@ -470,6 +473,6 @@ Rainer Tammer <tammer@tammer.net>
 
 =head1 DATE
 
-Version 0.0.10: 07 Aug 2009
+Version 0.0.11: 18 Jan 2010
 
 =cut
index a7c8df2..8d06c9f 100644 (file)
@@ -539,10 +539,13 @@ libswanted=`echo " $libswanted " | sed -e 's/ BSD / /'`
 d_flock='undef'
 
 # remove libgdbm from wanted libraries
-# The libgdbm 1.8.3 from the AIX Toolbox is not working 
-# (the dbm_store() function is defective)
-libswanted=`echo " $libswanted " | sed -e 's/ gdbm / /'`
-i_gdbm='undef'
-i_gdbmndbm='undef'
-
+# The libgdbm < 1.8.3-5 from the AIX Toolbox is not working
+# because two wrong .h are present
+if [ -f "/opt/freeware/include/gdbm/dbm.h" ] ||
+   [ -f "/opt/freeware/include/gdbm/ndbm.h" ]; then
+    echo "GDBM support disabled because your GDBM package contains extraneous headers - see README.aix."
+    libswanted=`echo " $libswanted " | sed -e 's/ gdbm / /'`
+    i_gdbm='undef'
+    i_gdbmndbm='undef'
+fi
 # EOF