This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
update Makefile notes on the now deprecated USE_5005THREADS and
authorGurusamy Sarathy <gsar@cpan.org>
Tue, 25 Jan 2000 19:21:17 +0000 (19:21 +0000)
committerGurusamy Sarathy <gsar@cpan.org>
Tue, 25 Jan 2000 19:21:17 +0000 (19:21 +0000)
USE_OBJECT

p4raw-id: //depot/perl@4890

win32/Makefile
win32/makefile.mk

index 88eb9d8..2a00255 100644 (file)
@@ -43,42 +43,47 @@ INST_VER    = \5.5.640
 INST_ARCH      = \$(ARCHNAME)
 
 #
-# XXX WARNING! This option currently undergoing changes.  May be broken.
+# uncomment to enable multiple interpreters.  This is need for fork()
+# emulation.
 #
-# uncomment to enable threads-capabilities
-#
-#USE_5005THREADS= define
+#USE_MULTI     = define
 
 #
-# XXX WARNING! This option currently undergoing changes.  May be broken.
+# XXX WARNING! This option is still very experimental.  May be broken.
 #
-# uncomment to enable multiple interpreters
+# Beginnings of interpreter cloning/threads; still very incomplete.
+# This should be enabled to get the fork() emulation.  This needs
+# USE_MULTI as well.
 #
-#USE_MULTI     = define
+#USE_ITHREADS  = define
 
 #
-# XXX WARNING! This option currently undergoing changes.  May be broken.
-#
-# uncomment next line if you want to use the perl object
-# Currently, this cannot be enabled if you ask for threads above
+# uncomment to enable the implicit "host" layer for all system calls
+# made by perl.  This needs USE_MULTI above.  This is also needed to
+# get fork().
 #
-#USE_OBJECT    = define
+#USE_IMP_SYS   = define
 
 #
-# XXX WARNING! This option currently undergoing changes.  May be broken.
+# WARNING! This option is deprecated and will eventually go away (enable
+# USE_ITHREADS instead).
 #
-# Beginnings of interpreter cloning/threads: still rather rough, fails
-# tests.  This should be enabled to get the fork() emulation.  This needs
-# one of USE_MULTI or USE_OBJECT enabled as well.
+# uncomment to enable threads-capabilities.  This is incompatible with
+# USE_ITHREADS, and is only here for people who may have come to rely
+# on the experimental Thread support that was in 5.005.
 #
-#USE_ITHREADS  = define
+#USE_5005THREADS= define
 
 #
-# uncomment to enable the implicit "host" layer for all system calls
-# made by perl.  This needs one of USE_MULTI or USE_OBJECT above.
-# This is also needed to get fork().
+# WARNING! This option is deprecated and will eventually go away (enable
+# USE_MULTI instead).
 #
-#USE_IMP_SYS   = define
+# uncomment next line if you want to use the PERL_OBJECT build option.
+# DO NOT ENABLE unless you have legacy code that relies on the C++
+# CPerlObj class that was available in 5.005.  This cannot be enabled
+# if you ask for USE_5005THREADS above.
+#
+#USE_OBJECT    = define
 
 #
 # uncomment one of the following lines if you are using either
@@ -132,7 +137,7 @@ INST_ARCH   = \$(ARCHNAME)
 # WARNING: Turning this on/off WILL break binary compatibility with extensions
 # you may have compiled with/without it.  Be prepared to recompile all
 # extensions if you change the default.  Currently, this cannot be enabled
-# if you ask for USE_OBJECT above.
+# if you ask for USE_IMP_SYS above.
 #
 #PERL_MALLOC   = define
 
@@ -222,6 +227,10 @@ USE_5005THREADS    = undef
 USE_ITHREADS   = undef
 !ENDIF
 
+!IF "$(USE_IMP_SYS)" == "define"
+PERL_MALLOC    = undef
+!ENDIF
+
 !IF "$(USE_MULTI)" == ""
 USE_MULTI      = undef
 !ENDIF
index 9a44722..5736366 100644 (file)
@@ -47,43 +47,47 @@ INST_VER    *= \5.5.640
 INST_ARCH      *= \$(ARCHNAME)
 
 #
-# XXX WARNING! This option currently undergoing changes.  May be broken.
+# uncomment to enable multiple interpreters.  This is need for fork()
+# emulation.
 #
-# uncomment to enable threads-capabilities
-#
-#USE_5005THREADS       *= define
+#USE_MULTI     *= define
 
 #
-# XXX WARNING! This option currently undergoing changes.  May be broken.
+# XXX WARNING! This option is still very experimental.  May be broken.
 #
-# uncomment to enable multiple interpreters
+# Beginnings of interpreter cloning/threads; still very incomplete.
+# This should be enabled to get the fork() emulation.  This needs
+# USE_MULTI as well.
 #
-#USE_MULTI     *= define
+#USE_ITHREADS  *= define
 
 #
-# XXX WARNING! This option currently undergoing changes.  May be broken.
-#
-# uncomment next line if you want to use the perl object
-# Currently, this cannot be enabled if you ask for threads above, or
-# if you are using GCC or EGCS.
+# uncomment to enable the implicit "host" layer for all system calls
+# made by perl.  This needs USE_MULTI above.  This is also needed to
+# get fork().
 #
-#USE_OBJECT    *= define
+#USE_IMP_SYS   *= define
 
 #
-# XXX WARNING! This option currently undergoing changes.  May be broken.
+# WARNING! This option is deprecated and will eventually go away (enable
+# USE_ITHREADS instead).
 #
-# Beginnings of interpreter cloning/threads: still rather rough, fails
-# tests.  This should be enabled to get the fork() emulation.  This needs
-# one of USE_MULTI or USE_OBJECT enabled as well.
+# uncomment to enable threads-capabilities.  This is incompatible with
+# USE_ITHREADS, and is only here for people who may have come to rely
+# on the experimental Thread support that was in 5.005.
 #
-#USE_ITHREADS  *= define
+#USE_5005THREADS       *= define
 
 #
-# uncomment to enable the implicit "host" layer for all system calls
-# made by perl.  This needs one of USE_MULTI or USE_OBJECT above.
-# This is also needed to get fork().
+# WARNING! This option is deprecated and will eventually go away (enable
+# USE_MULTI instead).
 #
-#USE_IMP_SYS   *= define
+# uncomment next line if you want to use the PERL_OBJECT build option.
+# DO NOT ENABLE unless you have legacy code that relies on the C++
+# CPerlObj class that was available in 5.005.  This cannot be enabled
+# if you ask for USE_5005THREADS above.
+#
+#USE_OBJECT    *= define
 
 #
 # uncomment exactly one of the following
@@ -150,7 +154,7 @@ CCTYPE              *= BORLAND
 # WARNING: Turning this on/off WILL break binary compatibility with extensions
 # you may have compiled with/without it.  Be prepared to recompile all
 # extensions if you change the default.  Currently, this cannot be enabled
-# if you ask for USE_OBJECT above.
+# if you ask for USE_IMP_SYS above.
 #
 #PERL_MALLOC   *= define
 
@@ -243,6 +247,10 @@ USE_5005THREADS    *= undef
 USE_ITHREADS   != undef
 .ENDIF
 
+.IF "$(USE_IMP_SYS)" == "define"
+PERL_MALLOC    != undef
+.ENDIF
+
 USE_MULTI      *= undef
 USE_OBJECT     *= undef
 USE_ITHREADS   *= undef