This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
ExtUtils::MakeMaker 6.54
authorDavid Mitchell <davem@iabyn.com>
Fri, 10 Jul 2009 14:16:14 +0000 (15:16 +0100)
committerDavid Mitchell <davem@iabyn.com>
Fri, 10 Jul 2009 14:17:28 +0000 (15:17 +0100)
33 files changed:
MANIFEST
Porting/Maintainers.pl
lib/ExtUtils/Changes
lib/ExtUtils/Command/MM.pm
lib/ExtUtils/Liblist.pm
lib/ExtUtils/Liblist/Kid.pm
lib/ExtUtils/MM.pm
lib/ExtUtils/MM_AIX.pm
lib/ExtUtils/MM_Any.pm
lib/ExtUtils/MM_BeOS.pm
lib/ExtUtils/MM_Cygwin.pm
lib/ExtUtils/MM_DOS.pm
lib/ExtUtils/MM_Darwin.pm
lib/ExtUtils/MM_MacOS.pm
lib/ExtUtils/MM_NW5.pm
lib/ExtUtils/MM_OS2.pm
lib/ExtUtils/MM_QNX.pm
lib/ExtUtils/MM_UWIN.pm
lib/ExtUtils/MM_Unix.pm
lib/ExtUtils/MM_VMS.pm
lib/ExtUtils/MM_VOS.pm
lib/ExtUtils/MM_Win32.pm
lib/ExtUtils/MM_Win95.pm
lib/ExtUtils/MY.pm
lib/ExtUtils/MakeMaker.pm
lib/ExtUtils/MakeMaker/Config.pm
lib/ExtUtils/Mkbootstrap.pm
lib/ExtUtils/Mksymlists.pm
lib/ExtUtils/t/fix_libs.t
lib/ExtUtils/t/installed_file.t
lib/ExtUtils/t/is_of_type.t
lib/ExtUtils/t/test_boilerplate.t [new file with mode: 0644]
lib/ExtUtils/testlib.pm

index f115e84..85cbd13 100644 (file)
--- a/MANIFEST
+++ b/MANIFEST
@@ -2230,6 +2230,7 @@ lib/ExtUtils/t/Constant.t See if ExtUtils::Constant works
 lib/ExtUtils/t/cp.t            See if ExtUtils::Command works
 lib/ExtUtils/t/dir_target.t    Verify if dir_target() is supported
 lib/ExtUtils/t/Embed.t         See if ExtUtils::Embed and embedding works
+lib/ExtUtils/t/test_boilerplate.t MakeMaker test
 lib/ExtUtils/testlib.pm                Fixes up @INC to use just-built extension
 lib/ExtUtils/t/eu_command.t    See if ExtUtils::Command works
 lib/ExtUtils/t/FIRST_MAKEFILE.t                See if FIRST_MAKEFILE works
index 697aa4f..4a90b40 100755 (executable)
@@ -694,7 +694,7 @@ package Maintainers;
     'ExtUtils::MakeMaker' =>
        {
        'MAINTAINER'    => 'mschwern',
-       'DISTRIBUTION'  => 'MSCHWERN/ExtUtils-MakeMaker-6.53_03.tar.gz',
+       'DISTRIBUTION'  => 'MSCHWERN/ExtUtils-MakeMaker-6.54.tar.gz',
                            # note that t/lib/TieOut.pm is included in
                            # more than one distro
        'FILES'         => q[lib/ExtUtils/{Liblist,MakeMaker,Mkbootstrap,Mksymlists,MM*,MY,testlib}.pm
index 88c431e..bacd445 100644 (file)
@@ -1,3 +1,9 @@
+6.54  Tue Jul  7 16:48:22 PDT 2009
+    Test Fixes
+    * Added perl core boilerplate code to a few new tests which were missing
+      them.
+
+
 6.53_03  Thu Jul  2 14:47:45 PDT 2009
     Bug Fixes
     * You'd get a warning if you had a PREREQ_PM on a module with no $VERSION
index e13baa9..8748d79 100644 (file)
@@ -10,7 +10,7 @@ our @ISA = qw(Exporter);
 
 our @EXPORT  = qw(test_harness pod2man perllocal_install uninstall 
                   warn_if_old_packlist);
-our $VERSION = '6.53_03';
+our $VERSION = '6.54';
 
 my $Is_VMS = $^O eq 'VMS';
 
index 94fb8ef..ae33db5 100644 (file)
@@ -2,7 +2,7 @@ package ExtUtils::Liblist;
 
 use strict;
 
-our $VERSION = '6.53_03';
+our $VERSION = '6.54';
 
 use File::Spec;
 require ExtUtils::Liblist::Kid;
index adb8a48..730b4d0 100644 (file)
@@ -9,7 +9,7 @@ use 5.006;
 # Broken out of MakeMaker from version 4.11
 
 use strict;
-our $VERSION = 6.53_03;
+our $VERSION = 6.54;
 
 use Config;
 use Cwd 'cwd';
index 39e3b4d..d3ff875 100644 (file)
@@ -3,7 +3,7 @@ package ExtUtils::MM;
 use strict;
 use ExtUtils::MakeMaker::Config;
 
-our $VERSION = '6.53_03';
+our $VERSION = '6.54';
 
 require ExtUtils::Liblist;
 require ExtUtils::MakeMaker;
index e0dc539..dcfb171 100644 (file)
@@ -1,7 +1,7 @@
 package ExtUtils::MM_AIX;
 
 use strict;
-our $VERSION = '6.53_03';
+our $VERSION = '6.54';
 
 require ExtUtils::MM_Unix;
 our @ISA = qw(ExtUtils::MM_Unix);
index 9a971b4..ce723b5 100644 (file)
@@ -1,7 +1,7 @@
 package ExtUtils::MM_Any;
 
 use strict;
-our $VERSION = '6.53_03';
+our $VERSION = '6.54';
 
 use Carp;
 use File::Spec;
index 1629333..3c8978a 100644 (file)
@@ -26,7 +26,7 @@ require ExtUtils::MM_Any;
 require ExtUtils::MM_Unix;
 
 our @ISA = qw( ExtUtils::MM_Any ExtUtils::MM_Unix );
-our $VERSION = '6.53_03';
+our $VERSION = '6.54';
 
 
 =item os_flavor
index e57d004..79894e2 100644 (file)
@@ -9,7 +9,7 @@ require ExtUtils::MM_Unix;
 require ExtUtils::MM_Win32;
 our @ISA = qw( ExtUtils::MM_Unix );
 
-our $VERSION = '6.53_03';
+our $VERSION = '6.54';
 
 
 =head1 NAME
index af80bde..fd7f28e 100644 (file)
@@ -2,7 +2,7 @@ package ExtUtils::MM_DOS;
 
 use strict;
 
-our $VERSION = 6.53_03;
+our $VERSION = 6.54;
 
 require ExtUtils::MM_Any;
 require ExtUtils::MM_Unix;
index b3a90a0..39d469e 100644 (file)
@@ -7,7 +7,7 @@ BEGIN {
     our @ISA = qw( ExtUtils::MM_Unix );
 }
 
-our $VERSION = '6.53_03';
+our $VERSION = '6.54';
 
 
 =head1 NAME
index 3e42998..54b656e 100644 (file)
@@ -2,7 +2,7 @@ package ExtUtils::MM_MacOS;
 
 use strict;
 
-our $VERSION = 6.53_03;
+our $VERSION = 6.54;
 
 sub new {
     die <<'UNSUPPORTED';
index 6efd4a4..536959a 100644 (file)
@@ -22,7 +22,7 @@ use strict;
 use ExtUtils::MakeMaker::Config;
 use File::Basename;
 
-our $VERSION = '6.53_03';
+our $VERSION = '6.54';
 
 require ExtUtils::MM_Win32;
 our @ISA = qw(ExtUtils::MM_Win32);
index 6b780a7..183c8b4 100644 (file)
@@ -5,7 +5,7 @@ use strict;
 use ExtUtils::MakeMaker qw(neatvalue);
 use File::Spec;
 
-our $VERSION = '6.53_03';
+our $VERSION = '6.54';
 
 require ExtUtils::MM_Any;
 require ExtUtils::MM_Unix;
index bd97c3a..190e3ca 100644 (file)
@@ -1,7 +1,7 @@
 package ExtUtils::MM_QNX;
 
 use strict;
-our $VERSION = '6.53_03';
+our $VERSION = '6.54';
 
 require ExtUtils::MM_Unix;
 our @ISA = qw(ExtUtils::MM_Unix);
index ea59ef5..f5c2f50 100644 (file)
@@ -1,7 +1,7 @@
 package ExtUtils::MM_UWIN;
 
 use strict;
-our $VERSION = 6.53_03;
+our $VERSION = 6.54;
 
 require ExtUtils::MM_Unix;
 our @ISA = qw(ExtUtils::MM_Unix);
index 59a612a..81dc41b 100644 (file)
@@ -15,7 +15,7 @@ use ExtUtils::MakeMaker qw($Verbose neatvalue);
 
 # If we make $VERSION an our variable parse_version() breaks
 use vars qw($VERSION);
-$VERSION = '6.53_03';
+$VERSION = '6.54';
 
 require ExtUtils::MM_Any;
 our @ISA = qw(ExtUtils::MM_Any);
index f524b2b..96b8a97 100644 (file)
@@ -15,7 +15,7 @@ BEGIN {
 
 use File::Basename;
 
-our $VERSION = '6.53_03';
+our $VERSION = '6.54';
 
 require ExtUtils::MM_Any;
 require ExtUtils::MM_Unix;
index af703eb..b09b954 100644 (file)
@@ -1,7 +1,7 @@
 package ExtUtils::MM_VOS;
 
 use strict;
-our $VERSION = '6.53_03';
+our $VERSION = '6.54';
 
 require ExtUtils::MM_Unix;
 our @ISA = qw(ExtUtils::MM_Unix);
index 5e5aaf2..bd5f15b 100644 (file)
@@ -27,7 +27,7 @@ use ExtUtils::MakeMaker qw( neatvalue );
 require ExtUtils::MM_Any;
 require ExtUtils::MM_Unix;
 our @ISA = qw( ExtUtils::MM_Any ExtUtils::MM_Unix );
-our $VERSION = '6.53_03';
+our $VERSION = '6.54';
 
 $ENV{EMXSHELL} = 'sh'; # to run `commands`
 
index 52bfca4..fc1be24 100644 (file)
@@ -2,7 +2,7 @@ package ExtUtils::MM_Win95;
 
 use strict;
 
-our $VERSION = '6.53_03';
+our $VERSION = '6.54';
 
 require ExtUtils::MM_Win32;
 our @ISA = qw(ExtUtils::MM_Win32);
index 5d14b3e..e38e404 100644 (file)
@@ -3,7 +3,7 @@ package ExtUtils::MY;
 use strict;
 require ExtUtils::MM;
 
-our $VERSION = 6.53_03;
+our $VERSION = 6.54;
 our @ISA = qw(ExtUtils::MM);
 
 {
index 2d140be..9b021e1 100644 (file)
@@ -18,7 +18,7 @@ our @Overridable;
 my @Prepend_parent;
 my %Recognized_Att_Keys;
 
-our $VERSION = '6.53_03';
+our $VERSION = '6.54';
 
 # Emulate something resembling CVS $Revision$
 (our $Revision = $VERSION) =~ s{_}{};
index fc028ba..5b58ab3 100644 (file)
@@ -2,7 +2,7 @@ package ExtUtils::MakeMaker::Config;
 
 use strict;
 
-our $VERSION = '6.53_03';
+our $VERSION = '6.54';
 
 use Config ();
 
index 5684934..37e2404 100644 (file)
@@ -3,7 +3,7 @@ package ExtUtils::Mkbootstrap;
 # There's just too much Dynaloader incest here to turn on strict vars.
 use strict 'refs';
 
-our $VERSION = '6.53_03';
+our $VERSION = '6.54';
 
 require Exporter;
 our @ISA = ('Exporter');
index f9d517c..ce57289 100644 (file)
@@ -10,7 +10,7 @@ use Config;
 
 our @ISA = qw(Exporter);
 our @EXPORT = qw(&Mksymlists);
-our $VERSION = '6.53_03';
+our $VERSION = '6.54';
 
 sub Mksymlists {
     my(%spec) = @_;
index c683fc5..2a9bf0c 100644 (file)
@@ -2,8 +2,16 @@
 
 # Unit test the code which fixes up $self->{LIBS}
 
+BEGIN {
+    chdir 't' if -d 't';
+
+    if( $ENV{PERL_CORE} ) {
+        @INC = '../lib';
+    }
+}
+
 use strict;
-use lib 't/lib';
+use lib './lib';
 use Test::More 'no_plan';
 
 use ExtUtils::MakeMaker;
index ebb6585..c2dfce7 100644 (file)
@@ -2,10 +2,18 @@
 
 # Test MM->_installed_file_for_module()
 
+BEGIN {
+    chdir 't' if -d 't';
+
+    if( $ENV{PERL_CORE} ) {
+        @INC = '../lib';
+    }
+}
+
 use strict;
 use warnings;
 
-use lib 't/lib';
+use lib './lib';
 use ExtUtils::MakeMaker;
 use Test::More;
 use File::Spec;
index d123ee3..8a95d0d 100644 (file)
@@ -2,6 +2,15 @@
 
 # Test _is_of_type()
 
+BEGIN {
+    chdir 't' if -d 't';
+
+    if( $ENV{PERL_CORE} ) {
+        @INC = '../lib';
+    }
+}
+
+use lib './lib';
 use strict;
 use ExtUtils::MakeMaker;
 
diff --git a/lib/ExtUtils/t/test_boilerplate.t b/lib/ExtUtils/t/test_boilerplate.t
new file mode 100644 (file)
index 0000000..899ad57
--- /dev/null
@@ -0,0 +1,26 @@
+#!/usr/bin/perl -w
+
+# <<<Fill in with what this test does.>>>
+# Copy this when writing new tests to avoid forgetting the core boilerplate
+
+# Magic for core
+BEGIN {
+    # Always run in t to unify behavor with core
+    chdir 't' if -d 't';
+
+    # Only use the about to be installed modules
+    if( $ENV{PERL_CORE} ) {
+        @INC = '../lib';
+    }
+}
+
+# Use things from t/lib/
+use lib './lib';
+use strict;
+use ExtUtils::MakeMaker;
+
+use Test::More;
+
+pass("Your test code goes here");
+
+done_testing();
index ab0ab89..0af41d2 100644 (file)
@@ -3,7 +3,7 @@ package ExtUtils::testlib;
 use strict;
 use warnings;
 
-our $VERSION = 6.53_03;
+our $VERSION = 6.54;
 
 use Cwd;
 use File::Spec;