This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Release managers need to be careful in INSTALL
authorFlorian Ragwitz <rafl@debian.org>
Mon, 16 Aug 2010 23:06:29 +0000 (01:06 +0200)
committerFlorian Ragwitz <rafl@debian.org>
Mon, 16 Aug 2010 23:06:29 +0000 (01:06 +0200)
Everything is binary incompatible with each other, except for maint releases
from the same maint branch.

Porting/release_managers_guide.pod

index fa1895f..2d192fc 100644 (file)
@@ -340,6 +340,11 @@ I<You MUST SKIP this step for SNAPSHOT>
 Review and update INSTALL to account for the change in version number;
 in particular, the "Coexistence with earlier versions of perl 5" section.
 
 Review and update INSTALL to account for the change in version number;
 in particular, the "Coexistence with earlier versions of perl 5" section.
 
+Be particularly careful with the section "Upgrading from 5.X.Y or earlier". For
+stable releases, this needs to refer to the last release in the previous
+development cycle. For blead releases, it needs to refer to the previous blead
+release.
+
 =item *
 
 I<You MUST SKIP this step for SNAPSHOT>
 =item *
 
 I<You MUST SKIP this step for SNAPSHOT>