This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
perldiag: Rmv obsolete statement
authorKarl Williamson <khw@cpan.org>
Sat, 11 Jan 2020 17:53:57 +0000 (10:53 -0700)
committerKarl Williamson <khw@cpan.org>
Mon, 13 Jan 2020 04:19:46 +0000 (21:19 -0700)
Code points this large are no longer legal on a 32 bit platform.

pod/perldiag.pod

index 3b7c2c7..58e27e7 100644 (file)
@@ -1740,8 +1740,6 @@ Acceptance of these code points is a Perl extension, and you should
 expect that nothing other than Perl can handle them; Perl itself on
 EBCDIC platforms before v5.24 does not handle them.
 
 expect that nothing other than Perl can handle them; Perl itself on
 EBCDIC platforms before v5.24 does not handle them.
 
-Code points above 0xFFFF_FFFF require larger than a 32 bit word.
-
 Perl also makes no guarantees that the representation of these code
 points won't change at some point in the future, say when machines
 become available that have larger than a 64-bit word.  At that time,
 Perl also makes no guarantees that the representation of these code
 points won't change at some point in the future, say when machines
 become available that have larger than a 64-bit word.  At that time,