This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Mention common dynaloader errors in perldiag.pod
authorJos I. Boumans <kane@dwim.org>
Wed, 21 Jul 2004 13:47:35 +0000 (15:47 +0200)
committerRafael Garcia-Suarez <rgarciasuarez@gmail.com>
Wed, 21 Jul 2004 12:01:32 +0000 (12:01 +0000)
From: "Jos I. Boumans" <kane@dwim.org>
Message-Id: <C226C05A-DB0B-11D8-A551-000A95EF62E2@dwim.org>
(with tweaks)

p4raw-id: //depot/perl@23146

pod/perldiag.pod

index 8541645..0d5abdc 100644 (file)
@@ -784,6 +784,16 @@ usually double the curlies to get the same effect though, because the
 inner curlies will be considered a block that loops once.  See
 L<perlfunc/last>.
 
+=item Can't load '%s' for module %s
+
+(F) The module you tried to load failed to load a dynamic extension. This
+may either mean that you upgraded your version of perl to one that is
+incompatible with your old dynamic extensions (which is known to happen
+between major versions of perl), or (more likely) that your dynamic
+extension was build against an older version of the library that is
+installed on your system. You may need to rebuild your old dynamic
+extensions.
+
 =item Can't localize lexical variable %s
 
 (F) You used local on a variable name that was previously declared as a
@@ -815,6 +825,12 @@ autoload, but there is no function to autoload.  Most probable causes
 are a misprint in a function/method name or a failure to C<AutoSplit>
 the file, say, by doing C<make install>.
 
+=item Can't locate loadable object for module %s in @INC
+
+(F) The module you loaded is trying to load an external library, like
+for example, C<foo.so> or C<bar.dll>, but the L<DynaLoader> module was
+unable to locate this library.  See L<DynaLoader>.
+
 =item Can't locate object method "%s" via package "%s"
 
 (F) You called a method correctly, and it correctly indicated a package