This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Update Parse-CPAN-Meta to CPAN version 1.4402
authorChris 'BinGOs' Williams <chris@bingosnet.co.uk>
Wed, 8 Feb 2012 09:51:30 +0000 (09:51 +0000)
committerChris 'BinGOs' Williams <chris@bingosnet.co.uk>
Wed, 8 Feb 2012 12:28:33 +0000 (12:28 +0000)
  [DELTA]

  1.4402 Tue Feb 07 2012
      - Minor maintenance: standardized newlines to Unix style

Porting/Maintainers.pl
cpan/Parse-CPAN-Meta/Changes
cpan/Parse-CPAN-Meta/lib/Parse/CPAN/Meta.pm
pod/perldelta.pod

index b2a1dc9..9bb8882 100755 (executable)
@@ -1365,7 +1365,7 @@ use File::Glob qw(:case);
 
     'Parse::CPAN::Meta' => {
         'MAINTAINER'   => 'dagolden',
-        'DISTRIBUTION' => 'DAGOLDEN/Parse-CPAN-Meta-1.4401.tar.gz',
+        'DISTRIBUTION' => 'DAGOLDEN/Parse-CPAN-Meta-1.4402.tar.gz',
         'FILES'        => q[cpan/Parse-CPAN-Meta],
         'EXCLUDED'     => [],
         'UPSTREAM'     => 'cpan',
index 68ac154..d9e3df9 100644 (file)
@@ -1,5 +1,8 @@
 Changes for Perl programming language extension Parse-CPAN-Meta
 
+1.4402 Tue Feb 07 2012
+      - Minor maintenance: standardized newlines to Unix style
+
 1.4401 Fri Feb 04 2011
       - Removed Module::Load::Conditional dependency
 
index f7d717c..04ac3e1 100644 (file)
@@ -5,7 +5,7 @@ use Carp 'croak';
 
 # UTF Support?
 sub HAVE_UTF8 () { $] >= 5.007003 }
-sub IO_LAYER () { $] >= 5.008001 ? ":utf8" : "" }
+sub IO_LAYER () { $] >= 5.008001 ? ":utf8" : "" }  
 
 BEGIN {
        if ( HAVE_UTF8 ) {
@@ -17,7 +17,7 @@ BEGIN {
        # Class structure
        require 5.004;
        require Exporter;
-       $Parse::CPAN::Meta::VERSION   = '1.4401';
+       $Parse::CPAN::Meta::VERSION   = '1.4402';
        @Parse::CPAN::Meta::ISA       = qw{ Exporter      };
        @Parse::CPAN::Meta::EXPORT_OK = qw{ Load LoadFile };
 }
@@ -40,7 +40,7 @@ sub load_yaml_string {
   my ($class, $string) = @_;
   my $backend = $class->yaml_backend();
   my $data = eval { no strict 'refs'; &{"$backend\::Load"}($string) };
-  if ( $@ ) {
+  if ( $@ ) { 
     croak $backend->can('errstr') ? $backend->errstr : $@
   }
   return $data || {}; # in case document was valid but empty
@@ -88,7 +88,7 @@ sub _slurp {
     or die "can't open $_[0] for reading: $!";
   return do { local $/; <$fh> };
 }
-
+  
 sub _can_load {
   my ($module, $version) = @_;
   (my $file = $module) =~ s{::}{/}g;
@@ -133,21 +133,21 @@ Parse::CPAN::Meta - Parse META.yml and META.json CPAN metadata files
 
     #############################################
     # In your file
-
+    
     ---
     name: My-Distribution
     version: 1.23
     resources:
       homepage: "http://example.com/dist/My-Distribution"
-
-
+    
+    
     #############################################
     # In your program
-
+    
     use Parse::CPAN::Meta;
-
+    
     my $distmeta = Parse::CPAN::Meta->load_file('META.yml');
-
+    
     # Reading properties
     my $name     = $distmeta->{name};
     my $version  = $distmeta->{version};
@@ -196,7 +196,7 @@ C<load_yaml_string>.
 
   my $metadata_structure = Parse::CPAN::Meta->load_json_string($json_string);
 
-This method deserializes the given string of JSON and the result.
+This method deserializes the given string of JSON and the result.  
 If the source was UTF-8 encoded, the string must be decoded before calling
 C<load_json_string>.
 
index 70fd1cb..4996dd1 100644 (file)
@@ -319,6 +319,10 @@ correctly; use of C<package_versions_from_directory> is discouraged.
 
 =item *
 
+L<Parse::CPAN::Meta> has been upgraded from version 1.4401 to version 1.4402.
+
+=item *
+
 L<Pod::Parser> has been upgraded from version 1.37 to version 1.51.
 
 =item *