This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
AIX Hints file change
authorDarin McBride <dmcbride@cpan.org>
Mon, 25 Jun 2012 23:36:32 +0000 (17:36 -0600)
committerH.Merijn Brand <h.m.brand@xs4all.nl>
Wed, 27 Jun 2012 06:23:49 +0000 (08:23 +0200)
Ok, I think my earlier problem came from not cleaning up properly between
multiple compiles.  So I don't need to modify any test.

Proposed log entry:

When compiling many of the perl modules available from CPAN, an expectation
of C99 support seems implied by many authors.  Unfortunately, xlC doesn't
do this by default, we have to add -qlanglvl=extc99 to the ccflags to get
this to work.  And by the time we get to installing modules, this flag
is already set in Config.

So, add the flag unconditionally at the outset.  Also, remove
-qlonglong and -qlanglvl=extended from the flags to silence the warning that
extc99 includes them and that xlC is going to ignore it, using extc99 instead.

Signed-off-by: H.Merijn Brand <h.m.brand@xs4all.nl>

No differences found