This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Fix some typos in threads.pm
authorJerry D. Hedden <jdhedden@cpan.org>
Sun, 19 Aug 2007 13:53:17 +0000 (09:53 -0400)
committerAbhijit Menon-Sen <ams@wiw.org>
Mon, 20 Aug 2007 08:19:13 +0000 (08:19 +0000)
From: "Jerry D. Hedden" <jdhedden@cpan.org>
Message-Id: <1ff86f510708191053x36f35619yaa019db70a623612@mail.gmail.com>

p4raw-id: //depot/perl@31736

ext/threads/threads.pm

index e75d9d5..1fa0ee0 100755 (executable)
@@ -859,16 +859,16 @@ problem.
 
 =over
 
 
 =over
 
-=item Threadsafe modules
+=item Thread-safe modules
 
 See L<perlmod/"Making your module threadsafe"> when creating modules that may
 be used in threaded applications, especially if those modules use non-Perl
 data, or XS code.
 
 
 See L<perlmod/"Making your module threadsafe"> when creating modules that may
 be used in threaded applications, especially if those modules use non-Perl
 data, or XS code.
 
-=item Using non-threadsafe modules
+=item Using non-thread-safe modules
 
 
-Unfortunately, you may encounter Perl modules that are not I<threadsafe>.  For
-example, they may crash the Perl interpreter during execution, or may dump
+Unfortunately, you may encounter Perl modules that are not I<thread-safe>.
+For example, they may crash the Perl interpreter during execution, or may dump
 core on termination.  Depending on the module and the requirements of your
 application, it may be possible to work around such difficulties.
 
 core on termination.  Depending on the module and the requirements of your
 application, it may be possible to work around such difficulties.
 
@@ -968,12 +968,12 @@ reconstituting it in the joining thread.
 =item Perl Bugs and the CPAN Version of L<threads>
 
 Support for threads extends beyond the code in this module (i.e.,
 =item Perl Bugs and the CPAN Version of L<threads>
 
 Support for threads extends beyond the code in this module (i.e.,
-F<threads.pm> and F<threads.xs>), and into the Perl iterpreter itself.  Older
+F<threads.pm> and F<threads.xs>), and into the Perl interpreter itself.  Older
 versions of Perl contain bugs that may manifest themselves despite using the
 latest version of L<threads> from CPAN.  There is no workaround for this other
 versions of Perl contain bugs that may manifest themselves despite using the
 latest version of L<threads> from CPAN.  There is no workaround for this other
-than upgrading to the lastest version of Perl.
+than upgrading to the latest version of Perl.
 
 
-Even with the lastest version of Perl, it is known that certain constructs
+Even with the latest version of Perl, it is known that certain constructs
 with threads may result in warning messages concerning leaked scalars or
 unreferenced scalars.  However, such warnings are harmless, and may safely be
 ignored.
 with threads may result in warning messages concerning leaked scalars or
 unreferenced scalars.  However, such warnings are harmless, and may safely be
 ignored.