This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
squelch known scalar leak due to compile failure
authorGurusamy Sarathy <gsar@cpan.org>
Sun, 19 Mar 2000 16:47:14 +0000 (16:47 +0000)
committerGurusamy Sarathy <gsar@cpan.org>
Sun, 19 Mar 2000 16:47:14 +0000 (16:47 +0000)
p4raw-id: //depot/perl@5828

t/pragma/strict-vars

index d0e82c4..3d98c54 100644 (file)
@@ -151,6 +151,8 @@ $d = 1;$i = 1;$n = 1;
 $e = 1;$j = 1;$o = 1;
 $p = 0b12;
 --FILE-- 
+# known scalar leak
+BEGIN { $ENV{PERL_DESTRUCT_LEVEL} = 0 unless $ENV{PERL_DESTRUCT_LEVEL} > 3; }
 use abc;
 EXPECT
 Global symbol "$f" requires explicit package name at abc.pm line 3.
@@ -169,8 +171,8 @@ Global symbol "$o" requires explicit package name at abc.pm line 7.
 Global symbol "$p" requires explicit package name at abc.pm line 8.
 Illegal binary digit '2' at abc.pm line 8, at end of line
 abc.pm has too many errors.
-Compilation failed in require at - line 1.
-BEGIN failed--compilation aborted at - line 1.
+Compilation failed in require at - line 3.
+BEGIN failed--compilation aborted at - line 3.
 ########
 
 # Check scope of pragma with eval