This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
For TSA we want 4 or later clang, not just later.
authorJarkko Hietaniemi <jhi@iki.fi>
Wed, 2 Dec 2015 17:19:40 +0000 (12:19 -0500)
committerJarkko Hietaniemi <jhi@iki.fi>
Wed, 2 Dec 2015 17:19:40 +0000 (12:19 -0500)
(Noticed by Aaron Crane.)

perl.h

diff --git a/perl.h b/perl.h
index 9032507..1e7afa0 100644 (file)
--- a/perl.h
+++ b/perl.h
@@ -3074,7 +3074,7 @@ freeing any remaining Perl interpreters.
     !defined(SWIG) && \
   ((!defined(__apple_build_version__) &&               \
     ((__clang_major__ == 3 && __clang_minor__ >= 5) || \
     !defined(SWIG) && \
   ((!defined(__apple_build_version__) &&               \
     ((__clang_major__ == 3 && __clang_minor__ >= 5) || \
-     (__clang_major__ > 4))) || \
+     (__clang_major__ >= 4))) || \
    (defined(__apple_build_version__) &&                \
     ((__clang_major__ >= 6))))
 #  define PERL_TSA__(x)   __attribute__((x))
    (defined(__apple_build_version__) &&                \
     ((__clang_major__ >= 6))))
 #  define PERL_TSA__(x)   __attribute__((x))