This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Upgrade to Module-Build-0.2803
authorSteve Peters <steve@fisharerojo.org>
Sun, 16 Jul 2006 15:40:29 +0000 (15:40 +0000)
committerSteve Peters <steve@fisharerojo.org>
Sun, 16 Jul 2006 15:40:29 +0000 (15:40 +0000)
p4raw-id: //depot/perl@28587

lib/Module/Build.pm
lib/Module/Build/Base.pm
lib/Module/Build/Changes

index c58143c..5e9c777 100644 (file)
@@ -15,7 +15,7 @@ use Module::Build::Base;
 
 use vars qw($VERSION @ISA);
 @ISA = qw(Module::Build::Base);
-$VERSION = '0.2802';
+$VERSION = '0.2803';
 $VERSION = eval $VERSION;
 
 # Okay, this is the brute-force method of finding out what kind of
index 3e7ebdb..5007da2 100644 (file)
@@ -3211,6 +3211,8 @@ sub prepare_metadata {
     die "ERROR: Missing required field '$_' for META.yml\n"
       unless defined($node->{$name}) && length($node->{$name});
   }
+  # Really don't understand why I need the "... if exists" here
+  $node->{version} = $node->{version}->stringify if exists $node->{version};
 
   if (defined( $self->license ) &&
       defined( my $url = $self->valid_licenses->{ $self->license } )) {
@@ -3228,7 +3230,7 @@ sub prepare_metadata {
   }
   my $pkgs = eval { $self->find_dist_packages };
   if ($@) {
-    $self->log_warn("WARNING: Possible missing or corrupt 'MANIFEST' file.\n" .
+    $self->log_warn("$@\nWARNING: Possible missing or corrupt 'MANIFEST' file.\n" .
                    "Nothing to enter for 'provides' field in META.yml\n");
   } else {
     $node->{provides} = $pkgs if %$pkgs;
@@ -3379,6 +3381,11 @@ sub find_dist_packages {
     }
   }
 
+  # Stringify versions
+  for (grep exists $_->{version}, values %prime) {
+    $_->{version} = $_->{version}->stringify;
+  }
+
   return \%prime;
 }
 
index 3547b49..6a0959b 100644 (file)
@@ -1,5 +1,10 @@
 Revision history for Perl extension Module::Build.
 
+0.2803  Sat Jul 15 08:26:34 CDT 2006
+
+ - The META.yml file in the last release was all screwed up, so the
+   distribution wasn't indexed properly.  Fixed in this release.
+
 0.2802  Fri Jul 14 22:40:34 CDT 2006
 
  - Added reliance on version.pm, which means we should deal much