This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Update DB_File from CPAN version 1.838 to 1.840.
authorJames E Keenan <jkeenan@cpan.org>
Thu, 29 Dec 2016 17:39:12 +0000 (12:39 -0500)
committerJames E Keenan <jkeenan@cpan.org>
Thu, 29 Dec 2016 17:39:12 +0000 (12:39 -0500)
From Changes:

    1.840 29 Dec 2016

       * #119569: Failed to install DB_File-1.839 into Linux

    1.839 29 Dec 2016

       * #119557: DB_File.xs: unused-parameter warnings
       * #107642: unused arg

Porting/Maintainers.pl
cpan/DB_File/DB_File.pm
cpan/DB_File/DB_File.xs

index 2820dad..5050e22 100755 (executable)
@@ -335,7 +335,7 @@ use File::Glob qw(:case);
     },
 
     'DB_File' => {
     },
 
     'DB_File' => {
-        'DISTRIBUTION' => 'PMQS/DB_File-1.838.tar.gz',
+        'DISTRIBUTION' => 'PMQS/DB_File-1.840.tar.gz',
         'FILES'        => q[cpan/DB_File],
         'EXCLUDED'     => [
             qr{^patches/},
         'FILES'        => q[cpan/DB_File],
         'EXCLUDED'     => [
             qr{^patches/},
index 8e40902..5f4b764 100644 (file)
@@ -163,7 +163,7 @@ our ($db_version, $use_XSLoader, $splice_end_array_no_length, $splice_end_array,
 use Carp;
 
 
 use Carp;
 
 
-$VERSION = "1.838" ;
+$VERSION = "1.840" ;
 $VERSION = eval $VERSION; # needed for dev releases
 
 {
 $VERSION = eval $VERSION; # needed for dev releases
 
 {
index f417b22..04c8f74 100644 (file)
@@ -607,6 +607,9 @@ const DBT * key2 ;
 #ifdef AT_LEAST_DB_3_2
     PERL_UNUSED_ARG(db);
 #endif
 #ifdef AT_LEAST_DB_3_2
     PERL_UNUSED_ARG(db);
 #endif
+#ifdef AT_LEAST_DB_6_0
+    PERL_UNUSED_ARG(locp);
+#endif
 
     if (CurrentDB->in_compare) {
         tidyUp(CurrentDB);
 
     if (CurrentDB->in_compare) {
         tidyUp(CurrentDB);