This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Update Term-UI to CPAN version 0.24
authorChris 'BinGOs' Williams <chris@bingosnet.co.uk>
Wed, 12 Jan 2011 13:37:39 +0000 (13:37 +0000)
committerChris 'BinGOs' Williams <chris@bingosnet.co.uk>
Wed, 12 Jan 2011 13:37:39 +0000 (13:37 +0000)
  [DELTA]

  Changes for 0.24        Wed Jan 12 13:16:01 GMT 2011
  =====================================================
  * Skip some tests if we are not on a terminal

Porting/Maintainers.pl
cpan/Term-UI/lib/Term/UI.pm
cpan/Term-UI/t/02_ui.t
pod/perldelta.pod

index d910e45..15eb3fb 100755 (executable)
@@ -1373,7 +1373,7 @@ use File::Glob qw(:case);
     'Term::UI' =>
        {
        'MAINTAINER'    => 'kane',
-       'DISTRIBUTION'  => 'BINGOS/Term-UI-0.22.tar.gz',
+       'DISTRIBUTION'  => 'BINGOS/Term-UI-0.24.tar.gz',
        'FILES'         => q[cpan/Term-UI],
        'UPSTREAM'      => 'cpan',
        },
index 9776570..ca1ca7c 100644 (file)
@@ -11,7 +11,7 @@ use strict;
 BEGIN {
     use vars        qw[$VERSION $AUTOREPLY $VERBOSE $INVALID];
     $VERBOSE    =   1;
-    $VERSION    =   '0.22';
+    $VERSION    =   '0.24';
     $INVALID    =   loc('Invalid selection, please try again: ');
 }
 
index 6e0b34a..3a8a320 100644 (file)
@@ -11,6 +11,11 @@ use_ok( 'Term::UI' );
 $Term::UI::AUTOREPLY    = $Term::UI::AUTOREPLY  = 1;
 $Term::UI::VERBOSE      = $Term::UI::VERBOSE    = 0;
 
+# SKIP tests if we aren't on a terminal
+SKIP: {
+
+skip 'not on a terminal', 18 unless -t;
+
 ### enable warnings
 $^W = 1;
 
@@ -142,3 +147,5 @@ my $tmpl = {
         is( $rest, $munged,     "   Command parsed correctly" );
     }
 }
+
+} # End SKIP block
index 706d58d..8370e04 100644 (file)
@@ -198,7 +198,7 @@ C<Params::Check> has been upgraded from version 0.26 to 0.28
 
 =item *
 
-C<Term::UI> has been upgraded from version 0.20 to 0.22
+C<Term::UI> has been upgraded from version 0.20 to 0.24
 
 =item *