This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
perl.exp was not built in time on systems that required it (AIX, ...)
authorH.Merijn Brand <h.m.brand@xs4all.nl>
Mon, 9 Nov 2009 15:24:24 +0000 (16:24 +0100)
committerH.Merijn Brand <h.m.brand@xs4all.nl>
Mon, 9 Nov 2009 15:24:24 +0000 (16:24 +0100)
and it always needed that, but re-ordering of targets has exposed that

Makefile.SH

index 9589ada..832e643 100644 (file)
@@ -1151,7 +1151,7 @@ manicheck:        FORCE
 $(DYNALOADER): $(MINIPERL_EXE) preplibrary FORCE $(nonxs_ext)
        $(MINIPERL) make_ext.pl $@ MAKE=$(MAKE) LIBPERL_A=$(LIBPERL) LINKTYPE=static $(STATIC_LDFLAGS)
 
-d_dummy $(dynamic_ext):        $(MINIPERL_EXE) preplibrary makeppport $(DYNALOADER) FORCE
+d_dummy $(dynamic_ext):        $(MINIPERL_EXE) preplibrary makeppport $(DYNALOADER) FORCE $(PERLEXPORT)
        $(MINIPERL) make_ext.pl $@ MAKE=$(MAKE) LIBPERL_A=$(LIBPERL) LINKTYPE=dynamic
 
 s_dummy $(static_ext): $(MINIPERL_EXE) preplibrary makeppport $(DYNALOADER) FORCE