This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Change to check if _POSIX_OPEN_MAX is 16 or 20, however the entire test is kind of...
authorArtur Bergman <sky@nanisky.com>
Tue, 5 Feb 2002 11:20:21 +0000 (11:20 +0000)
committerArtur Bergman <sky@nanisky.com>
Tue, 5 Feb 2002 11:20:21 +0000 (11:20 +0000)
p4raw-id: //depot/perl@14558

ext/POSIX/t/posix.t

index 49357a6..3e00af5 100644 (file)
@@ -91,7 +91,8 @@ SKIP: {
     skip("_POSIX_OPEN_MAX is inaccurate on MPE", 1) if $Is_MPE;
     skip("_POSIX_OPEN_MAX undefined ($fds[1])",  1) unless &_POSIX_OPEN_MAX;
 
-    ok( &_POSIX_OPEN_MAX > $fds[1], '_POSIX_OPEN_MAX' );
+    ok( &_POSIX_OPEN_MAX == 16 || &_POSIX_OPEN_MAX == 20, "The two allowed values according to susv2 and susv3" );
+
 }
 
 my $pat;