This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Update Module-Metadata to CPAN version 1.000009
authorChris 'BinGOs' Williams <chris@bingosnet.co.uk>
Wed, 8 Feb 2012 18:24:00 +0000 (18:24 +0000)
committerChris 'BinGOs' Williams <chris@bingosnet.co.uk>
Wed, 8 Feb 2012 18:24:00 +0000 (18:24 +0000)
  [DELTA]

  1.0.9 2012-02-08 12:00:00
    - API of 'provides' changed to require a 'version' argument to future
      proof the function against CPAN Meta Spec changes (DAGOLDEN)
    - Fatal errors now use 'croak' instead of 'die'; Carp added as
      prerequisite (DAGOLDEN)

Porting/Maintainers.pl
cpan/Module-Metadata/lib/Module/Metadata.pm
cpan/Module-Metadata/t/metadata.t
pod/perldelta.pod

index 455fc69..99f9969 100755 (executable)
@@ -1272,7 +1272,7 @@ use File::Glob qw(:case);
 
     'Module::Metadata' => {
         'MAINTAINER'   => 'dagolden',
-        'DISTRIBUTION' => 'DAGOLDEN/Module-Metadata-1.000008.tar.gz',
+        'DISTRIBUTION' => 'DAGOLDEN/Module-Metadata-1.000009.tar.gz',
         'FILES'        => q[cpan/Module-Metadata],
         'EXCLUDED'     => [
             qr{^maint},
index 52394a3..e52a0e2 100644 (file)
@@ -11,9 +11,10 @@ package Module::Metadata;
 
 use strict;
 use vars qw($VERSION);
-$VERSION = '1.000008';
+$VERSION = '1.000009';
 $VERSION = eval $VERSION;
 
+use Carp qw/croak/;
 use File::Spec;
 use IO::File;
 use version 0.87;
@@ -163,12 +164,18 @@ sub new_from_module {
   sub provides {
     my $class = shift;
 
-    die "provides() requires key/value pairs \n" if @_ % 2;
+    croak "provides() requires key/value pairs \n" if @_ % 2;
     my %args = @_;
 
-    die "provides() takes only one of 'dir' or 'files'\n"
+    croak "provides() takes only one of 'dir' or 'files'\n"
       if $args{dir} && $args{files};
 
+    croak "provides() requires a 'version' argument"
+      unless defined $args{version};
+
+    croak "provides() does not support version '$args{version}' metadata"
+        unless grep { $args{version} eq $_ } qw/1.4 2/;
+
     $args{prefix} = 'lib' unless defined $args{prefix};
 
     my $p;
@@ -176,7 +183,7 @@ sub new_from_module {
       $p = $class->package_versions_from_directory($args{dir});
     }
     else {
-      die "provides() requires 'files' to be an array reference\n"
+      croak "provides() requires 'files' to be an array reference\n"
         unless ref $args{files} eq 'ARRAY';
       $p = $class->package_versions_from_directory($args{files});
     }
@@ -227,7 +234,7 @@ sub new_from_module {
   
         if ( $package eq $prime_package ) {
           if ( exists( $prime{$package} ) ) {
-            die "Unexpected conflict in '$package'; multiple versions found.\n";
+            croak "Unexpected conflict in '$package'; multiple versions found.\n";
           } else {
             $prime{$package}{file} = $mapped_filename;
             $prime{$package}{version} = $version if defined( $version );
@@ -379,7 +386,7 @@ sub _init {
 # class method
 sub _do_find_module {
   my $class   = shift;
-  my $module  = shift || die 'find_module_by_name() requires a package name';
+  my $module  = shift || croak 'find_module_by_name() requires a package name';
   my $dirs    = shift || \@INC;
 
   my $file = File::Spec->catfile(split( /::/, $module));
@@ -429,7 +436,7 @@ sub _parse_file {
 
   my $filename = $self->{filename};
   my $fh = IO::File->new( $filename )
-    or die( "Can't open '$filename': $!" );
+    or croak( "Can't open '$filename': $!" );
 
   $self->_parse_fh($fh);
 }
@@ -586,15 +593,15 @@ sub _evaluate_version_line {
   warn "Error evaling version line '$eval' in $self->{filename}: $@\n"
     if $@;
   (ref($vsub) eq 'CODE') or
-    die "failed to build version sub for $self->{filename}";
+    croak "failed to build version sub for $self->{filename}";
   my $result = eval { $vsub->() };
-  die "Could not get version from $self->{filename} by executing:\n$eval\n\nThe fatal error was: $@\n"
+  croak "Could not get version from $self->{filename} by executing:\n$eval\n\nThe fatal error was: $@\n"
     if $@;
 
   # Upgrade it into a version object
   my $version = eval { _dwim_version($result) };
 
-  die "Version '$result' from $self->{filename} does not appear to be valid:\n$eval\n\nThe fatal error was: $@\n"
+  croak "Version '$result' from $self->{filename} does not appear to be valid:\n$eval\n\nThe fatal error was: $@\n"
     unless defined $version; # "0" is OK!
 
   return $version;
@@ -652,7 +659,7 @@ sub _evaluate_version_line {
       last if defined $version;
     }
 
-    die $error unless defined $version;
+    croak $error unless defined $version;
 
     return $version;
   }
@@ -706,7 +713,9 @@ Module::Metadata - Gather package and POD information from perl module files
   my $version = $info->version;
 
   # CPAN META 'provides' field for .pm files in a directory
-  my $provides = Module::Metadata->provides(dir => 'lib');
+  my $provides = Module::Metadata->provides(
+    dir => 'lib', version => 2
+  );
 
 =head1 DESCRIPTION
 
@@ -767,6 +776,16 @@ pairs.  Valid option keys include:
 
 =over
 
+=item version B<(required)>
+
+Specifies which version of the L<CPAN::Meta::Spec> should be used as
+the format of the C<provides> output.  Currently only '1.4' and '2'
+are supported (and their format is identical).  This may change in
+the future as the definition of C<provides> changes.
+
+The C<version> option is required.  If it is omitted or if
+an unsupported version is given, then C<provides> will throw an error.
+
 =item dir
 
 Directory to search recursively for F<.pm> files.  May not be specified with
index b93cefb..ab9c8c4 100644 (file)
@@ -550,7 +550,7 @@ is_deeply( $got_pvfd, $exp_pvfd, "package_version_from_directory()" )
   or diag explain $got_pvfd;
 
 {
-  my $got_provides = Module::Metadata->provides(dir => 'lib');
+  my $got_provides = Module::Metadata->provides(dir => 'lib', version => 2);
   my $exp_provides = {
     'Simple' => {
       'file' => 'lib/Simple.pm',
@@ -567,7 +567,7 @@ is_deeply( $got_pvfd, $exp_pvfd, "package_version_from_directory()" )
 }
 
 {
-  my $got_provides = Module::Metadata->provides(dir => 'lib', prefix => 'other');
+  my $got_provides = Module::Metadata->provides(dir => 'lib', prefix => 'other', version => 1.4);
   my $exp_provides = {
     'Simple' => {
       'file' => 'other/Simple.pm',
index 4996dd1..cf38e2f 100644 (file)
@@ -312,7 +312,7 @@ This avoids a new core warning.
 
 =item *
 
-L<Module::Metadata> has been upgraded from version 1.000007 to version 1.000008.
+L<Module::Metadata> has been upgraded from version 1.000007 to version 1.000009.
 
 Adds C<provides> method to generate a CPAN META provides data structure
 correctly; use of C<package_versions_from_directory> is discouraged.