This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Describe how to limit the perl's default @INC during Configure
authorH.Merijn Brand <h.m.brand@xs4all.nl>
Mon, 19 Jan 2004 16:05:50 +0000 (16:05 +0000)
committerH.Merijn Brand <h.m.brand@xs4all.nl>
Mon, 19 Jan 2004 16:05:50 +0000 (16:05 +0000)
to _not_ include older versions

p4raw-id: //depot/perl@22175

INSTALL

diff --git a/INSTALL b/INSTALL
index 69cceb5..2c93839 100644 (file)
--- a/INSTALL
+++ b/INSTALL
@@ -238,6 +238,20 @@ defaults from then on.
 After it runs, Configure will perform variable substitution on all the
 *.SH files and offer to run make depend.
 
+=head2 Disabling older versions of Perl
+
+Configure will search for binary compatible versions of previously
+installed perl binaries in the tree that is specified as target tree
+and these will be used by the perl being built.
+
+To disable use of older perl modules, even completely valid pure perl
+modules, you can specify to not include the pathes found:
+
+       sh Configure -Dinc_version_list=none ...
+
+When using the newer perl, you can add these pathes again in the
+$PERL5LIB environment variable or with perl's -I runtime option.
+
 =head2 Altering config.sh variables for C compiler switches etc.
 
 For most users, all of the Configure defaults are fine.  Configure