This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
[MERGE] fix require's croak message
authorDavid Mitchell <davem@iabyn.com>
Tue, 18 Apr 2017 12:14:10 +0000 (13:14 +0100)
committerDavid Mitchell <davem@iabyn.com>
Tue, 18 Apr 2017 12:14:10 +0000 (13:14 +0100)
RT #131098

This branch fixes two issues with the message produced when
require croaks.

First it mentioned @INC even when @INC wasn't scanned, and second it
emitted the "you may need to install Foo::Bar module" hint even when the
failed-to-load pathname wasn't reverse-mappable to a module name.


Trivial merge