This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
RMG - Put all version-bump related information about INSTALL in one place
authorSteve Hay <steve.m.hay@googlemail.com>
Sat, 31 Jan 2015 15:19:40 +0000 (15:19 +0000)
committerSteve Hay <steve.m.hay@googlemail.com>
Sat, 31 Jan 2015 15:19:40 +0000 (15:19 +0000)
Also correct the phrase referred to by the RMG to match what INSTALL
actualy says, and change the wording of one section of INSTALL to match the
other.

INSTALL
Porting/release_managers_guide.pod

diff --git a/INSTALL b/INSTALL
index 7fa0701..e2c7a10 100644 (file)
--- a/INSTALL
+++ b/INSTALL
@@ -89,7 +89,7 @@ potential incompatibilities introduced with this release.  A few of
 the most important issues are listed below, but you should refer
 to pod/perldelta.pod for more detailed information.
 
-B<WARNING:> This version is not binary compatible with prior releases of Perl.
+B<WARNING:> This version is not binary compatible with earlier versions of Perl.
 If you have built extensions (i.e. modules that include C code)
 using an earlier version of Perl, you will need to rebuild and reinstall
 those extensions.
index a37ea2e..1a503b3 100644 (file)
@@ -388,8 +388,7 @@ Use git status and git diff to select changes you want to keep.
 Be particularly careful with F<INSTALL>, which contains a mixture of
 C<5.10.0>-type strings, some of which need bumping on every release, and
 some of which need to be left unchanged.
-The line in F<INSTALL> about "is binary incompatible with" requires a
-correct choice of earlier version to declare incompatibility with.
+See below in L<"update INSTALL"> for more details.
 
 For the first RC release leading up to a BLEAD-FINAL release, update the
 description of which releases are now "officially" supported in
@@ -442,8 +441,11 @@ version number.
 
 =head3 update INSTALL
 
-Review and update INSTALL to account for the change in version number;
-in particular, the "Coexistence with earlier versions of perl 5" section.
+Review and update INSTALL to account for the change in version number.
+The lines in F<INSTALL> about "is not binary compatible with" may require a
+correct choice of earlier version to declare incompatibility with. These are
+in the "Changes and Incompatibilities" and "Coexistence with earlier versions
+of perl 5" sections.
 
 Be particularly careful with the section "Upgrading from 5.X.Y or earlier".
 The "X.Y" needs to be changed to the most recent version that we are