This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Upgrade Data::Dumper to 2.131
authorSteffen Mueller <smueller@cpan.org>
Sat, 28 May 2011 12:17:25 +0000 (14:17 +0200)
committerSteffen Mueller <smueller@cpan.org>
Sat, 28 May 2011 12:17:25 +0000 (14:17 +0200)
This has no functional changes, just updating the version
and change log to match the stable CPAN release.

Porting/Maintainers.pl
dist/Data-Dumper/Changes
dist/Data-Dumper/Dumper.pm

index d8fc77a..93998d7 100755 (executable)
@@ -511,7 +511,7 @@ use File::Glob qw(:case);
     'Data::Dumper' =>
        {
        'MAINTAINER'    => 'p5p', # Not gsar. Not ilyam. Not really smueller
-       'DISTRIBUTION'  => 'SMUELLER/Data-Dumper-2.128.tar.gz',
+       'DISTRIBUTION'  => 'SMUELLER/Data-Dumper-2.131.tar.gz',
        'FILES'         => q[dist/Data-Dumper],
        'UPSTREAM'      => 'blead',
        },
index f96f2ce..d788b3b 100644 (file)
@@ -6,7 +6,28 @@ HISTORY - public release history for Data::Dumper
 
 =over 8
 
-=item 2.130 (date here)
+=item 2.131 (May 27 2011)
+
+Essentially the same as version 2.130_02, but a production release.
+
+=item 2.130_03 (May 20 2011)
+
+Essentially the same as version 2.130_02, but a CPAN release
+for the eventual 2.131.
+
+=item 2.130_02
+
+This was only shipped with the perl core, never released to CPAN.
+
+Convert overload.t to Test::More
+
+Fix some spelling errors
+
+Fix some compiler warnings
+
+Fix an out of bounds write in Data-Dumper with malformed utf8 input
+
+=item 2.130 (Nov 20 2010)
 
 C<Dumpxs> can now handle malformed UTF-8.
 
@@ -106,7 +127,7 @@ Minor release to fix Makefile.PL not accepting MakeMaker args.
 
 =item 2.08  (7 December 1997)
 
-Glob dumps don't output superfluous 'undef' anymore.
+Glob dumps don't output superflous 'undef' anymore.
 
 Fixes from Gisle Aas <gisle@aas.no> to make Dumper() work with
 overloaded strings in recent perls, and his new testsuite.
index 1c68c98..d30c66c 100644 (file)
@@ -9,7 +9,7 @@
 
 package Data::Dumper;
 
-$VERSION = '2.130_02'; # Don't forget to set version and release date in POD!
+$VERSION = '2.131'; # Don't forget to set version and release date in POD!
 
 #$| = 1;
 
@@ -1297,7 +1297,7 @@ modify it under the same terms as Perl itself.
 
 =head1 VERSION
 
-Version 2.130_02  (Dec 20 2010)
+Version 2.131  (May 27 2011)
 
 =head1 SEE ALSO