This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Set version directly in Windows config.xxx files
authorSteve Hay <steve.m.hay@googlemail.com>
Thu, 7 Jun 2012 07:48:09 +0000 (08:48 +0100)
committerSteve Hay <steve.m.hay@googlemail.com>
Thu, 7 Jun 2012 07:48:09 +0000 (08:48 +0100)
There is no need for doing it via a ~VERSION~ substitution string since
that is not used anywhere else.

win32/config.ce
win32/config.gc
win32/config.gc64
win32/config.gc64nox
win32/config.vc
win32/config.vc64
win32/config_sh.PL

index fd744b8..6ba1650 100644 (file)
@@ -1019,7 +1019,7 @@ vendorlib_stem=''
 vendorlibexp=''
 vendorprefix=''
 vendorprefixexp=''
-version='~VERSION~'
+version=''
 versiononly='undef'
 vi=''
 voidflags='15'
index 189d157..14d200b 100644 (file)
@@ -1072,7 +1072,7 @@ vendorprefix=''
 vendorprefixexp=''
 vendorscript=''
 vendorscriptexp=''
-version='~VERSION~'
+version=''
 version_patchlevel_string=''
 versiononly='undef'
 vi=''
index e3fd7f0..3c4368a 100644 (file)
@@ -1073,7 +1073,7 @@ vendorprefix=''
 vendorprefixexp=''
 vendorscript=''
 vendorscriptexp=''
-version='~VERSION~'
+version=''
 version_patchlevel_string=''
 versiononly='undef'
 vi=''
index fe0429a..9f41cbb 100644 (file)
@@ -1073,7 +1073,7 @@ vendorprefix=''
 vendorprefixexp=''
 vendorscript=''
 vendorscriptexp=''
-version='~VERSION~'
+version=''
 version_patchlevel_string=''
 versiononly='undef'
 vi=''
index 5d6c6af..3b19a64 100644 (file)
@@ -1072,7 +1072,7 @@ vendorprefix=''
 vendorprefixexp=''
 vendorscript=''
 vendorscriptexp=''
-version='~VERSION~'
+version=''
 version_patchlevel_string=''
 versiononly='undef'
 vi=''
index 195719f..dd7130b 100644 (file)
@@ -1072,7 +1072,7 @@ vendorprefix=''
 vendorprefixexp=''
 vendorscript=''
 vendorscriptexp=''
-version='~VERSION~'
+version=''
 version_patchlevel_string=''
 versiononly='undef'
 vi=''
index fb23ee7..7f56025 100644 (file)
@@ -76,7 +76,7 @@ if (-e $patch_file) {
     close $fh;
 }
 
-$opt{VERSION} = "$opt{PERL_REVISION}.$opt{PERL_VERSION}.$opt{PERL_SUBVERSION}";
+$opt{'version'} = "$opt{PERL_REVISION}.$opt{PERL_VERSION}.$opt{PERL_SUBVERSION}";
 $opt{'version_patchlevel_string'} = "version $opt{PERL_VERSION} subversion $opt{PERL_SUBVERSION}";
 $opt{'version_patchlevel_string'} .= " patch $opt{PERL_PATCHLEVEL}" if exists $opt{PERL_PATCHLEVEL};