This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
podcheck.t: Suppress entity out of range messages
authorKarl Williamson <public@khwilliamson.com>
Fri, 17 Jun 2011 19:39:08 +0000 (13:39 -0600)
committerKarl Williamson <public@khwilliamson.com>
Fri, 17 Jun 2011 19:56:46 +0000 (13:56 -0600)
podchecker emits these messages if an E<> is above 255.  But these
actually work, so the messages are improper.  podchecker is not maintained.

t/porting/known_pod_issues.dat
t/porting/podcheck.t

index 45a845a..2ddeb48 100644 (file)
@@ -323,7 +323,6 @@ pod/perlwin32.pod   Verbatim line length including indents exceeds 80 by    12
 pod/perlxs.pod Apparent internal link is missing its forward slash     1
 pod/perlxs.pod Verbatim line length including indents exceeds 80 by    4
 pod/perlxstut.pod      Verbatim line length including indents exceeds 80 by    10
-porting/epigraphs.pod  Entity number out of range E<0x2014>    1
 porting/epigraphs.pod  Verbatim line length including indents exceeds 80 by    3
 porting/expand-macro.pl        Verbatim line length including indents exceeds 80 by    2
 porting/how_to_write_a_perldelta.pod   There is no NAME        1
index 9e946c2..a36081d 100644 (file)
@@ -265,6 +265,8 @@ my @suppressed_messages = (
     "multiple occurrence of link target",   # We catch independently the ones
                                             # that are real problems.
     "unescaped <>",
+    "Entity number out of range",   # Checker outputs this for anything above
+                                    # 255, and all Unicode is valid
 );
 
 sub suppressed {