This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
HP-UX 10.20 still *needs* -Ae for HP C-ANSI-C to be ANSI
authorH.Merijn Brand <h.m.brand@xs4all.nl>
Tue, 29 Jun 2004 10:57:46 +0000 (10:57 +0000)
committerH.Merijn Brand <h.m.brand@xs4all.nl>
Tue, 29 Jun 2004 10:57:46 +0000 (10:57 +0000)
11.00 and on are ANSI by default for /opt/ansic/bin
Error was introduced by #22975 in re-enabling 10.01

p4raw-id: //depot/perl@23007

hints/hpux.sh

index 335b3dd..8fe7092 100644 (file)
@@ -142,7 +142,7 @@ case `$cc -v 2>&1`"" in
                *)  ccflags="-Ae $cc_cppflags"
                    # +vnocompatwarnings not known in 10.10 and older
                    if [ $xxOsRev -ge 1020 ]; then
                *)  ccflags="-Ae $cc_cppflags"
                    # +vnocompatwarnings not known in 10.10 and older
                    if [ $xxOsRev -ge 1020 ]; then
-                       ccflags="$cc_cppflags -Wl,+vnocompatwarnings"
+                       ccflags="$ccflags -Wl,+vnocompatwarnings"
                        fi
                    ;;
                esac
                        fi
                    ;;
                esac