This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
APItest/t/utf8_warn_base.pl: Remove obsolete test
authorKarl Williamson <khw@cpan.org>
Mon, 19 Jun 2017 04:55:38 +0000 (22:55 -0600)
committerKarl Williamson <khw@cpan.org>
Thu, 13 Jul 2017 03:14:25 +0000 (21:14 -0600)
This was an attempt to test the fact that very high code points are
controlled both by regular above-Unicode warnings, and special,
non-portable warnings.  This test is now done better in the loop in the
file.

ext/XS-APItest/t/utf8_warn_base.pl

index 1ef448b..f2d13d0 100644 (file)
@@ -285,15 +285,6 @@ my @tests;
             0xFFFFFFFF,
             (isASCII) ? 1 : 8,
         ],
-        [ "requires at least 32 bits, and use SUPER-type flags, instead of"
-        . " ABOVE_31_BIT",
-            (isASCII)
-            ? "\xfe\x82\x80\x80\x80\x80\x80"
-            : I8_to_native(
-            "\xff\xa0\xa0\xa0\xa0\xa0\xa0\xa2\xa0\xa0\xa0\xa0\xa0\xa0"),
-            0x80000000,
-            1,
-        ],
     );
 
     if (! $::is64bit) {