This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
If perl's minimal required version number is >= 5.6.0,
authorRafael Garcia-Suarez <rgarciasuarez@gmail.com>
Thu, 6 Sep 2007 13:46:33 +0000 (13:46 +0000)
committerRafael Garcia-Suarez <rgarciasuarez@gmail.com>
Thu, 6 Sep 2007 13:46:33 +0000 (13:46 +0000)
we can write it 5.XXXXXX always. Fixes h2xs.t failiing
tests with 5.10.0.

p4raw-id: //depot/perl@31801

utils/h2xs.PL

index d16634c..c774d62 100644 (file)
@@ -658,9 +658,7 @@ if( $opt_b ){
            $sub ? sprintf("%d.%03d%02d",$maj,$min,$sub) :
                   sprintf("%d.%03d",    $maj,$min);
     } else {
-        $compat_version =
-           $sub ? sprintf("%d.%03d%03d",$maj,$min,$sub) :
-                  sprintf("%d.%03d",    $maj,$min);
+        $compat_version = sprintf("%d.%03d%03d",$maj,$min,$sub);
     }
 } else {
     my ($maj,$min,$sub) = $compat_version =~ /(\d+)\.(\d\d\d)(\d*)/;