This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Fix backward-compatibility issues in if.pm.
authorRafael Garcia-Suarez <rgarciasuarez@gmail.com>
Sun, 26 Oct 2003 14:59:53 +0000 (14:59 +0000)
committerRafael Garcia-Suarez <rgarciasuarez@gmail.com>
Sun, 26 Oct 2003 14:59:53 +0000 (14:59 +0000)
p4raw-id: //depot/perl@21540

lib/if.pm

index 6574d97..9e140c3 100644 (file)
--- a/lib/if.pm
+++ b/lib/if.pm
@@ -1,6 +1,6 @@
 package if;
 
-our $VERSION = '0.03';
+$VERSION = '0.04';
 
 sub work {
   my $method = shift() ? 'import' : 'unimport';
@@ -8,7 +8,7 @@ sub work {
 
   my $p = $_[0];               # PACKAGE
   (my $file = "$p.pm") =~ s!::!/!g;
-  require $file or die;
+  require $file;
 
   my $m = $p->can($method);
   goto &$m if $m;