This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Upgrade Unicode-Normalize from version 1.18 to 1.19
authorSteve Hay <steve.m.hay@googlemail.com>
Tue, 14 Jul 2015 08:29:06 +0000 (09:29 +0100)
committerSteve Hay <steve.m.hay@googlemail.com>
Tue, 14 Jul 2015 09:20:32 +0000 (10:20 +0100)
Porting/Maintainers.pl
cpan/Unicode-Normalize/Makefile.PL
cpan/Unicode-Normalize/Normalize.pm
pod/perldelta.pod

index bcb3a7c..c258f7d 100755 (executable)
@@ -1257,7 +1257,7 @@ use File::Glob qw(:case);
     },
 
     'Unicode::Normalize' => {
-        'DISTRIBUTION' => 'SADAHIRO/Unicode-Normalize-1.18.tar.gz',
+        'DISTRIBUTION' => 'SADAHIRO/Unicode-Normalize-1.19.tar.gz',
         'FILES'        => q[cpan/Unicode-Normalize],
     },
 
index 78199d2..a7b247b 100644 (file)
@@ -10,11 +10,9 @@ WriteMakefile(
     'NAME'              => 'Unicode::Normalize',
     'VERSION_FROM'      => 'Normalize.pm', # finds $VERSION
     'PREREQ_PM'         => {
-        bytes           => 0,
         Carp            => 0,
         constant        => 0,
         Exporter        => 0,
-        File::Copy      => 0,
         File::Spec      => 0,
         strict          => 0,
         warnings        => 0,
index b11df69..27514f2 100644 (file)
@@ -16,7 +16,7 @@ use Carp;
 
 no warnings 'utf8';
 
-our $VERSION = '1.18';
+our $VERSION = '1.19';
 our $PACKAGE = __PACKAGE__;
 
 our @EXPORT = qw( NFC NFD NFKC NFKD );
index fd52e76..dd22bf1 100644 (file)
@@ -183,6 +183,10 @@ C<$@> message which triggers the failure path inside C<open3>.
 
 L<Unicode::Collate> has been upgraded from version 1.12 to 1.14.
 
+=item *
+
+L<Unicode::Normalize> has been upgraded from version 1.18 to 1.19.
+
 =back
 
 =head2 Removed Modules and Pragmata