This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
update Math-Complex to CPAN version 1.59
authorZefram <zefram@fysh.org>
Wed, 1 Feb 2012 23:45:05 +0000 (23:45 +0000)
committerZefram <zefram@fysh.org>
Wed, 1 Feb 2012 23:45:05 +0000 (23:45 +0000)
* Don't declare "tan" operator overloading on Math::Complex
  objects, because there is no such overloading type [rt.cpan.org
  #74288].

* Remove execute bit from test scripts in CPAN tarball.

Porting/Maintainers.pl
cpan/Math-Complex/ChangeLog
cpan/Math-Complex/lib/Math/Complex.pm
cpan/Math-Complex/lib/Math/Trig.pm
pod/perldelta.pod

index d6b513f..dcd2621 100755 (executable)
@@ -1194,7 +1194,7 @@ use File::Glob qw(:case);
 
     'Math::Complex' => {
         'MAINTAINER'   => 'zefram',
-        'DISTRIBUTION' => 'ZEFRAM/Math-Complex-1.58.tar.gz',
+        'DISTRIBUTION' => 'ZEFRAM/Math-Complex-1.59.tar.gz',
         'FILES'        => q[cpan/Math-Complex],
         'EXCLUDED'     => [
             qw( t/pod.t
index 93d6980..f12c2d4 100644 (file)
@@ -1,3 +1,13 @@
+2012-02-01  Zefram  <zefram@fysh.org>
+
+       * Don't declare "tan" operator overloading on Math::Complex
+         objects, because there is no such overloading type [rt.cpan.org
+         #74288].
+
+       * Remove execute bit from test scripts in CPAN tarball.
+
+       * Release Math::Complex 1.59 + Math::Trig 1.23.
+
 2011-06-21  Zefram  <zefram@fysh.org>
 
        * Declare package variables with "our" rather than "use vars".
index f3a891b..19fb164 100644 (file)
@@ -10,7 +10,7 @@ package Math::Complex;
 { use 5.006; }
 use strict;
 
-our $VERSION = 1.58;
+our $VERSION = 1.59;
 
 use Config;
 
@@ -150,7 +150,6 @@ use overload
        'log'   => \&log,
        'sin'   => \&sin,
        'cos'   => \&cos,
-       'tan'   => \&tan,
        'atan2' => \&atan2,
         '""'    => \&_stringify;
 
index 3298240..1d9612a 100644 (file)
@@ -9,13 +9,13 @@ package Math::Trig;
 { use 5.006; }
 use strict;
 
-use Math::Complex 1.57;
+use Math::Complex 1.59;
 use Math::Complex qw(:trig :pi);
 require Exporter;
 
 our @ISA = qw(Exporter);
 
-our $VERSION = 1.22;
+our $VERSION = 1.23;
 
 my @angcnv = qw(rad2deg rad2grad
                deg2rad deg2grad
index 24e1914..c92bb87 100644 (file)
@@ -174,6 +174,12 @@ L<IPC::Cmd> has been upgraded from version 0.72 to version 0.76.
 
 =item *
 
+L<Math::Complex> has been upgraded from version 1.58 to version 1.59.
+
+This avoids a new core warning.
+
+=item *
+
 L<Pod::Parser> has been upgraded from version 1.37 to version 1.51.
 
 =item *