This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
In taint.t, violates_taint() now tests more of the "insecure dependency" error.
authorNicholas Clark <nick@ccl4.org>
Mon, 28 Feb 2011 14:49:43 +0000 (14:49 +0000)
committerNicholas Clark <nick@ccl4.org>
Wed, 2 Mar 2011 09:13:23 +0000 (09:13 +0000)
commitef5cbc634680e1354b871bbe4ae1a70c8a136307
tree0f15f89d13bf45aed122b0339d8508d1033a0457
parent8184526b79673bde388a42bb3746c95a7c046d06
In taint.t, violates_taint() now tests more of the "insecure dependency" error.

Use the second parameter to determine the string to look for in the error
message, and add an optional third parameter for the test description, if it
should differ from the error message string.
t/op/taint.t