This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Switch some core modules to XSLoader
authorNicolas R <atoomic@cpan.org>
Wed, 13 Sep 2017 17:22:32 +0000 (11:22 -0600)
committerTodd Rinaldo <toddr@cpan.org>
Mon, 13 Nov 2017 21:34:50 +0000 (15:34 -0600)
commitb9a5a78fe9165a983bc689902ecc96cf490f92d0
treebfea598e9706aafbe398dde3d4bbcf7e8c74a888
parentc0cc035a1caba3801f53dc4dd08c44096ff04389
Switch some core modules to XSLoader

RT 132080: Remove perl 5.006 compatibilities with DynaLoader and use
XSLoader directly.

The traditional boiler plate to use XSLoader for Perl > 5.006 or
DynaLoader, does not make sense for core modules in perl 5.28+.
dist/PathTools/Changes
dist/PathTools/Cwd.pm
dist/Time-HiRes/Changes
dist/Time-HiRes/HiRes.pm
dist/Unicode-Normalize/Changes
dist/Unicode-Normalize/Normalize.pm