This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
APItest/t/utf8.t: Don't test above IV_MAX
authorKarl Williamson <khw@cpan.org>
Mon, 15 May 2017 15:54:40 +0000 (09:54 -0600)
committerKarl Williamson <khw@cpan.org>
Thu, 13 Jul 2017 03:14:24 +0000 (21:14 -0600)
commit6b3df8c630fe72d3bdc58dd86ca5406d92ffcde5
tree23baa583fbbe9f88f246697e8a220d6358f33385
parentc57307f27baa2bec4c17c982b73505a1353f3e3e
APItest/t/utf8.t: Don't test above IV_MAX

For 32-bit platforms, this means moving  the tests to the 64-bit only portion of
the file.  And it comments out the tests that are above 64-bit IV_MAX.

This is in preparation for IV_MAX being the upper legal limit for code
points.
ext/XS-APItest/t/utf8.t