This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
If IVSIZE == LONGSIZE, long cannot be beyond IV_MIN/IV_MAX.
authorJarkko Hietaniemi <jhi@iki.fi>
Wed, 24 Jun 2015 02:28:57 +0000 (22:28 -0400)
committerJarkko Hietaniemi <jhi@iki.fi>
Sat, 27 Jun 2015 03:09:44 +0000 (23:09 -0400)
commit188f97e0784c33fc827ad1bb43a02b2707e88fc0
tree8ec31bd68e34e50910ca8a0ef84e2fc6814a8870
parent07bd88da0f6c75e74e6c72ad5849aad6daaff68d
If IVSIZE == LONGSIZE, long cannot be beyond IV_MIN/IV_MAX.

It can be if LONGSIZE > IVSIZE, which should be rather rare
(since Perl aims for at least long, someone would have to
force IV to be 32 bits?)

Coverity CID 104770.
ext/POSIX/POSIX.xs