This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Bump minimum required Bison version to 2.4
authorDagfinn Ilmari Mannsåker <ilmari@ilmari.org>
Tue, 28 Jul 2020 13:06:34 +0000 (14:06 +0100)
committerDagfinn Ilmari Mannsåker <ilmari@ilmari.org>
Thu, 6 Aug 2020 13:55:10 +0000 (14:55 +0100)
commit0a2b3d8846bc5c68e42def5b83d657754b4d07ce
tree7390a273af73b7e68802aa755c4c029985b7ba72
parent68932db140076f5a7aa243f78fc4fc963acc09b5
Bump minimum required Bison version to 2.4

This lets us replace the deprecated `%pure-parser` directive with
`%define api.pure`, and get rid of some other conditional code.

Bison is only required for developers hacking on the grammar, since we
check in the generated code.  Bison 2.4 was released in 2008, and is
included in operating systems as old as Red Hat Enterprise Linux 6.
perly.act
perly.h
perly.tab
perly.y
pod/perldelta.pod
regen_perly.pl