X-Git-Url: https://perl5.git.perl.org/perl5.git/blobdiff_plain/1a3e4d88b41f19081e0a5b33dd7353a2ca889c7e..00e72b5512ae5ce7a2578078ebdc82f4c48d51ee:/README.aix?ds=sidebyside diff --git a/README.aix b/README.aix index def6cb9..3938387 100644 --- a/README.aix +++ b/README.aix @@ -23,8 +23,16 @@ for which you have to pay: B and B. If you decide to use either of these two (which is quite a lot easier than using gcc), be sure to upgrade to the latest available patch level. Currently: - xlC.C 3.1.4.8 or 3.6.6.0 - vac.C 4.4.0.3 or 5.0.2.3 + xlC.C 3.1.4.10 or 3.6.6.0 or 4.0.2.2 or 5.0.2.9 or 6.0.0.3 + vac.C 4.4.0.3 or 5.0.2.6 or 6.0.0.1 + +note that xlC has the OS version in the name as of version 4.0.2.0, so +you will find xlC.C for AIX-5.0 as package + + xlC.aix50.rte 5.0.2.0 or 6.0.0.3 + +subversions are not the same `latest' on all OS versions. For example, +the latest xlC-5 on aix41 is 5.0.2.9, while on aix43, it is 5.0.2.7. Perl can be compiled with either IBM's ANSI C compiler or with gcc. The former is recommended, as not only can it compile Perl with no @@ -46,9 +54,8 @@ team. Before installing the patches to the IBM C-compiler you need to know the level of patching for the Operating System. IBM's command 'oslevel' will -show the base, but is not always complete: - -For AIX 4.3: +show the base, but is not always complete (in this example oslevel shows +4.3.NULL, whereas the system might run most of 4.3.THREE): # oslevel 4.3.0.0 @@ -57,29 +64,13 @@ For AIX 4.3: bos.rte 4.3.2.0 COMMITTED Base Operating System Runtime # -For AIX 5.1: - - # oslevel - 5.1.0.0 - # lslpp -l | grep 'bos.rte ' - bos.rte 5.1.0.25 COMMITTED Base Operating System Runtime - bos.rte 5.1.0.25 COMMITTED Base Operating System Runtime - -As a side note, perl cannot be built without bos.adt.syscalls and -bos.adt.libm installed. - -For AIX 4.3: - - # lslpp -l | egrep "syscalls|libm" - bos.adt.libm 4.3.3.50 COMMITTED Base Application Development - bos.adt.syscalls 4.3.3.51 COMMITTED System Calls Application - # - -For AIX 5.1: +The same might happen to AIX 5.1 or other OS levels. As a side note, perl +cannot be built without bos.adt.syscalls and bos.adt.libm installed # lslpp -l | egrep "syscalls|libm" bos.adt.libm 5.1.0.25 COMMITTED Base Application Development - bos.adt.syscalls 5.1.0.25 COMMITTED System Calls Application + bos.adt.syscalls 5.1.0.36 COMMITTED System Calls Application + # =head2 Building Dynamic Extensions on AIX @@ -95,7 +86,7 @@ called runtime linking mode instead of the emulated interface that was used in Perl releases 5.6.1 and earlier or, for AIX releases 4.2 and earlier. This change does break backward compatibility with compiled modules from earlier perl releases. The change was made to make Perl -more compliant with other applications like Apache/modperl which are +more compliant with other applications like Apache/mod_perl which are using the AIX native interface. This change also enables the use of C++ code with static constructors and destructors in perl extensions, which was not possible using the emulated interface. @@ -106,7 +97,9 @@ All defaults for Configure can be used. If you've chosen to use vac 4, be sure to run 4.4.0.3. Older versions will turn up nasty later on. For vac 5 be sure to run at least 5.0.1.0, -but vac 5.0.2.1 or up is highly recommended. +but vac 5.0.2.6 or up is highly recommended. Note that since IBM has +removed vac 5.0.2.1 through 5.0.2.5 from the software depot, these +versions should be considered obsolete. Here's a brief lead of how to upgrade the compiler to the latest level. Of course this is subject to changes. You can only upgrade @@ -164,31 +157,68 @@ On AIX 4.2 using xlC, we continue: On AIX 4.3 using vac, we continue: - # lslpp -l | fgrep 'vac.C ' - vac.C 4.4.0.2 COMMITTED C for AIX Compiler - vac.C 4.4.0.0 COMMITTED C for AIX Compiler - # grep 'vac.C.4.4.0.*.bff' other.ll - -rw-rw-r-- 1 45776101 1 13466624 May 26 1999 vac.C.4.4.0.1.bff - -rw-rw-r-- 1 45776101 1 13473792 Aug 31 1999 vac.C.4.4.0.2.bff - -rw-rw-r-- 1 45776101 1 13480960 May 19 20:32 vac.C.4.4.0.3.bff - # wget ftp://ftp.software.ibm.com/aix/fixes/v4/other/vac.C.4.4.0.3.bff + # lslpp -l | grep 'vac.C ' + vac.C 5.0.2.2 COMMITTED C for AIX Compiler + vac.C 5.0.2.0 COMMITTED C for AIX Compiler + # grep 'vac.C.5.0.2.*.bff' other.ll + -rw-rw-r-- 1 45776101 1 13592576 Apr 16 2001 vac.C.5.0.2.0.bff + -rw-rw-r-- 1 45776101 1 14133248 Apr 9 2002 vac.C.5.0.2.3.bff + -rw-rw-r-- 1 45776101 1 14173184 May 20 2002 vac.C.5.0.2.4.bff + -rw-rw-r-- 1 45776101 1 14192640 Nov 22 2002 vac.C.5.0.2.6.bff + # wget ftp://ftp.software.ibm.com/aix/fixes/v4/other/vac.C.5.0.2.6.bff # -Then execute the following command, and fill in its choices +Likewise on all other OS levels. Then execute the following command, and +fill in its choices # smit install_update -> Install and Update from LATEST Available Software - * INPUT device / directory for software [ vac.C.4.4.0.3.bff ] + * INPUT device / directory for software [ vac.C.5.0.2.6.bff ] [ OK ] [ OK ] Follow the messages ... and you're done. +If you like a more web-like approach, a good start point can be +http://www14.software.ibm.com/webapp/download/downloadaz.jsp and click +"C for AIX", and follow the instructions. + +=head2 The usenm option + +If linking miniperl + + cc -o miniperl ... miniperlmain.o opmini.o perl.o ... -lm -lc ... + +causes error like this + + ld: 0711-317 ERROR: Undefined symbol: .aintl + ld: 0711-317 ERROR: Undefined symbol: .copysignl + ld: 0711-317 ERROR: Undefined symbol: .syscall + ld: 0711-317 ERROR: Undefined symbol: .eaccess + ld: 0711-317 ERROR: Undefined symbol: .setresuid + ld: 0711-317 ERROR: Undefined symbol: .setresgid + ld: 0711-317 ERROR: Undefined symbol: .setproctitle + ld: 0711-345 Use the -bloadmap or -bnoquiet option to obtain more information. + +you could retry with + + make realclean + rm config.sh + ./Configure -Dusenm ... + +which makes Configure to use the C tool when scanning for library +symbols, which usually is not done in AIX. + +Related to this, you probably should not use the C<-r> option of +Configure in AIX, because that affects of how the C tool is used. + =head2 Using GNU's gcc for building perl -Using gcc-3.0 (tested with 3.0.4) now works out of the box, as does the -most recent gcc-2.9 available directly from IBM (as part of their Linux -compatibility packages). +Using gcc-3.x (tested with 3.0.4, 3.1, and 3.2) now works out of the box, +as do recent gcc-2.9 builds available directly from IBM as part of their +Linux compatibility packages, available here: + + http://www.ibm.com/servers/aix/products/aixos/linux/ =head2 Using Large Files with Perl @@ -199,6 +229,20 @@ Should yield no problems. Threads seem to work OK, though at the moment not all tests pass when threads are used in combination with 64bit configurations. +You may get a warning when doing a threaded build: + + "pp_sys.c", line 4640.39: 1506-280 (W) Function argument assignment between types "unsigned char*" and "const void*" is not allowed. + +The exact line number may vary, but if the warning (W) comes from a line +line this + + hent = PerlSock_gethostbyaddr(addr, (Netdb_hlen_t) addrlen, addrtype); + +in the "pp_ghostent" function, you may ignore it safely. The warning +is caused by the reentrant variant of gethostbyaddr() having a slightly +different prototype than its non-reentrant variant, but the difference +is not really significant here. + =head2 64-bit Perl If your AIX is installed with 64-bit support, you can expect 64bit @@ -221,6 +265,6 @@ H.Merijn Brand =head1 DATE -Version 0.0.5: 21 May 2002 +Version 0.0.6: 23 Dec 2002 =cut