This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
bump perl version number to 5.15.1
[perl5.git] / INSTALL
diff --git a/INSTALL b/INSTALL
index c5b4564..45578b4 100644 (file)
--- a/INSTALL
+++ b/INSTALL
@@ -530,7 +530,7 @@ The directories set up by Configure fall into three broad categories.
 
 =item Directories for the perl distribution
 
-By default, Configure will use the following directories for 5.15.0.
+By default, Configure will use the following directories for 5.15.1.
 $version is the full perl version number, including subversion, e.g.
 5.12.3, and $archname is a string like sun4-sunos,
 determined by Configure.  The full definitions of all Configure
@@ -841,7 +841,7 @@ must contain a space separated list of directories under the site_perl
 directory, and has to include architecture-dependent directories separately,
 eg.
 
-       sh Configure -Dinc_version_list="5.15.0/x86_64-linux 5.14.0" ...
+       sh Configure -Dinc_version_list="5.15.1/x86_64-linux 5.14.0" ...
 
 When using the newer perl, you can add these paths again in the
 PERL5LIB environment variable or with perl's -I runtime option.
@@ -2373,9 +2373,9 @@ won't interfere with another version.  (The defaults guarantee this for
 libraries after 5.6.0, but not for executables. TODO?)  One convenient
 way to do this is by using a separate prefix for each version, such as
 
-       sh Configure -Dprefix=/opt/perl5.15.0
+       sh Configure -Dprefix=/opt/perl5.15.1
 
-and adding /opt/perl5.15.0/bin to the shell PATH variable.  Such users
+and adding /opt/perl5.15.1/bin to the shell PATH variable.  Such users
 may also wish to add a symbolic link /usr/local/bin/perl so that
 scripts can still start with #!/usr/local/bin/perl.
 
@@ -2388,13 +2388,13 @@ seriously consider using a separate directory, since development
 subversions may not have all the compatibility wrinkles ironed out
 yet.
 
-=head2 Upgrading from 5.14.1 or earlier
+=head2 Upgrading from 5.15.0 or earlier
 
-B<Perl 5.15.0 is binary incompatible with Perl 5.14.* and any earlier
+B<Perl 5.15.1 is binary incompatible with Perl 5.15.0 and any earlier
 Perl release.>  Perl modules having binary parts
 (meaning that a C compiler is used) will have to be recompiled to be
-used with 5.15.0.  If you find you do need to rebuild an extension with
-5.15.0, you may safely do so without disturbing the older
+used with 5.15.1.  If you find you do need to rebuild an extension with
+5.15.1, you may safely do so without disturbing the older
 installations.  (See L<"Coexistence with earlier versions of perl 5">
 above.)