This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
The DynaLoader test isn't happy with OpenBSD's libc.so.39.3.
[perl5.git] / ext / DynaLoader / t / DynaLoader.t
index 6c4b7f7..b97fc60 100644 (file)
@@ -37,7 +37,7 @@ can_ok( 'DynaLoader' => 'dl_load_file'            ); # defined in XS section
 can_ok( 'DynaLoader' => 'dl_load_flags'           ); # defined in Perl section
 can_ok( 'DynaLoader' => 'dl_undef_symbols'        ); # defined in XS section
 SKIP: {
-    skip "unloading unsupported on VMS", 1 if $^O eq 'VMS';
+    skip "unloading unsupported on $^O", 1 if ($^O eq 'VMS' || $^O eq 'darwin');
     can_ok( 'DynaLoader' => 'dl_unload_file'          ); # defined in XS section
 }
 
@@ -89,7 +89,7 @@ SKIP: {
     # (not at least by that name) that the dl_findfile()
     # could find.
     skip "dl_findfile test not appropriate on $^O", 1
-       if $^O =~ /(win32|vms)/i;
+       if $^O =~ /(win32|vms|openbsd)/i;
     # Play safe and only try this test if this system
     # looks pretty much Unix-like.
     skip "dl_findfile test not appropriate on $^O", 1
@@ -116,7 +116,7 @@ is( scalar @DynaLoader::dl_modules, scalar keys %modules, "checking number of it
 my @loaded_modules = @DynaLoader::dl_modules;
 for my $libref (reverse @DynaLoader::dl_librefs) {
   SKIP: {
-    skip "unloading unsupported on VMS", 2 if $^O eq 'VMS';
+    skip "unloading unsupported on $^O", 2 if ($^O eq 'VMS' || $^O eq 'darwin');
     my $module = pop @loaded_modules;
     my $r = eval { DynaLoader::dl_unload_file($libref) };
     is( $@, '', "calling dl_unload_file() for $module" );