This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Fast enabling of strictures when version 5.11.0 is required
[perl5.git] / t / comp / use.t
index 30e41bb..8546123 100755 (executable)
@@ -6,7 +6,7 @@ BEGIN {
     $INC{"feature.pm"} = 1; # so we don't attempt to load feature.pm
 }
 
-print "1..65\n";
+print "1..68\n";
 
 # Can't require test.pl, as we're testing the use/require mechanism here.
 
@@ -108,6 +108,15 @@ like ($@, qr/Perl v5.\d+.\d+ required--this is only \Q$^V\E, stopped/);
 # check that "use 5.11.0" (and higher) loads strictures
 eval 'use 5.11.0; ${"foo"} = "bar";';
 like ($@, qr/Can't use string \("foo"\) as a SCALAR ref while "strict refs" in use/);
+# but that they can be disabled
+eval 'use 5.11.0; no strict "refs"; ${"foo"} = "bar";';
+is ($@, "");
+# and they are properly scoped
+eval '{use 5.11.0;} ${"foo"} = "bar";';
+is ($@, "");
+# and this doesn't happen with require
+eval 'require 5.11.0; ${"foo"} = "bar";';
+is ($@, "");
 
 { use lib }    # check that subparse saves pending tokens