This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Fast enabling of strictures when version 5.11.0 is required
[perl5.git] / pp_ctl.c
index 75d98dd..eab9624 100644 (file)
--- a/pp_ctl.c
+++ b/pp_ctl.c
@@ -3258,12 +3258,9 @@ PP(pp_require)
        /* If a version >= 5.11.0 is requested, strictures are on by default! */
        if (PL_compcv &&
                vcmp(sv, sv_2mortal(upg_version(newSVnv(5.011000), FALSE))) >= 0) {
-           ENTER;
-           Perl_load_module(aTHX_ 0, newSVpvs("strict"), NULL, NULL, NULL);
-           LEAVE;
+           PL_hints |= (HINT_STRICT_REFS | HINT_STRICT_SUBS | HINT_STRICT_VARS);
        }
 
-
        RETPUSHYES;
     }
     name = SvPV_const(sv, len);