This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
fixup Perl_magic_freemglob()
[perl5.git] / README.vos
index 342973a..7249f49 100644 (file)
@@ -4,77 +4,65 @@ specially designed to be readable as is.
 
 =head1 NAME
 
-README.vos - Perl for Stratus VOS
+perlvos - Perl for Stratus OpenVOS
 
 =head1 SYNOPSIS
 
-This file contains notes for building perl on the Stratus VOS
+This file contains notes for building perl on the Stratus OpenVOS
 operating system.  Perl is a scripting or macro language that is
-popular on many systems.  See L<perlbook> for a number of good
-books on Perl.
-
-These are instructions for building Perl from source.  Most
-people can simply download a pre-compiled distribution from the
-VOS anonymous FTP site.  This version of Perl is not supported
-on VOS Release 14.2.0 or earlier releases.  If you are running
-VOS Release 14.3.0 or later, download Perl from
-ftp://ftp.stratus.com/pub/vos/posix/ga/ga.html.  Instructions
-for unbundling the Perl distribution file are at
-ftp://ftp.stratus.com/pub/vos/utility/utility.html.
+popular on many systems.  See L<perlbook> for a number of good books
+on Perl.
+
+These are instructions for building Perl from source.  This version of
+Perl requires the dynamic linking support that is found in OpenVOS
+Release 17.1 and thus is not supported on OpenVOS Release 17.0 or
+earlier releases.
 
 If you are running VOS Release 14.4.1 or later, you can obtain a
-pre-compiled, supported copy of perl by purchasing Release 2.0.1
-of the VOS GNU C++ and GNU Tools product from Stratus
-Technologies.
+pre-compiled, supported copy of perl by purchasing the GNU Tools
+product from Stratus Technologies.
 
-=head1 BUILDING PERL FOR VOS
+=head1 BUILDING PERL FOR OPENVOS
 
-To build perl from its source code, you must have a Continuum
-platform running VOS Release 14.5.0 or later, the STCP product,
-and the GNU C++ and GNU Tools, Release 2.0.1 or later.
+To build perl from its source code on the Stratus V Series platform
+you must have OpenVOS Release 17.1.0 or later, GNU Tools Release
+3.5 or later, and the C/POSIX Runtime Libraries.
 
-To build full perl using the supplied Configure script and
-makefiles, change to the "vos" subdirectory and type the command
-"compile_full_perl" or "start_process compile_full_perl".  This
-will configure, build, and test perl.  All of the test cases
-that are executed should pass.
+Follow the normal instructions for building perl; e.g, enter bash, run
+the Configure script, then use "gmake" to build perl.
 
-=head1 INSTALLING PERL IN VOS
+=head1 INSTALLING PERL IN OPENVOS
 
 =over 4
 
 =item 1
 
-If you have built perl using the Configure script, ensure that
-you have modify permission to C<< >system>ported >> and type
+After you have built perl using the Configure script, ensure that you
+have modify and default write permission to C<< >system>ported >> and
+all subdirectories.  Then type
 
      gmake install
 
 =item 2
 
-While there are currently no architecture-specific
-extensions or modules distributed with perl, the following
-directories can be used to hold such files:
+While there are currently no architecture-specific extensions or
+modules distributed with perl, the following directories can be
+used to hold such files (replace the string VERSION by the
+appropriate version number):
 
-     >system>ported>lib>perl5>5.9.0>68k
-     >system>ported>lib>perl5>5.9.0>860
-     >system>ported>lib>perl5>5.9.0>7100
-     >system>ported>lib>perl5>5.9.0>8000
+     >system>ported>lib>perl5>VERSION>i786
 
 =item 3
 
 Site-specific perl extensions and modules can be installed in one of
 two places.  Put architecture-independent files into:
 
-     >system>ported>lib>perl5>site_perl>5.9.0
+     >system>ported>lib>perl5>site_perl>VERSION
 
 Put site-specific architecture-dependent files into one of the
 following directories:
 
-     >system>ported>lib>perl5>site_perl>5.9.0>68k
-     >system>ported>lib>perl5>site_perl>5.9.0>860
-     >system>ported>lib>perl5>site_perl>5.9.0>7100
-     >system>ported>lib>perl5>site_perl>5.9.0>8000
+     >system>ported>lib>perl5>site_perl>VERSION>i786
 
 =item 4
 
@@ -83,41 +71,33 @@ to see the order in which Perl searches these directories.
 
 =back
 
-=head1 USING PERL IN VOS
+=head1 USING PERL IN OPENVOS
 
-=head2 Restrictions of Perl on VOS
+=head2 Restrictions of Perl on OpenVOS
 
-This port of Perl version 5 to VOS prefers Unix-style,
-slash-separated pathnames over VOS-style greater-than-separated
-pathnames.  VOS-style pathnames should work in most contexts, but
-if you have trouble, replace all greater-than characters by slash
-characters.  Because the slash character is used as a pathname
-delimiter, Perl cannot process VOS pathnames containing a slash
-character in a directory or file name; these must be renamed.
+This port of Perl version 5 prefers Unix-style, slash-separated
+pathnames over OpenVOS-style greater-than-separated pathnames.
+OpenVOS-style pathnames should work in most contexts, but if you have
+trouble, replace all greater-than characters by slash characters.
+Because the slash character is used as a pathname delimiter, Perl
+cannot process OpenVOS pathnames containing a slash character in a
+directory or file name; these must be renamed.
 
 This port of Perl also uses Unix-epoch date values internally.
 As long as you are dealing with ASCII character string
 representations of dates, this should not be an issue.  The
 supported epoch is January 1, 1980 to January 17, 2038.
 
-See the file pod/perlport.pod for more information about the VOS
+See the file pod/perlport.pod for more information about the OpenVOS
 port of Perl.
 
-=head2 Handling of underflow and overflow
-
-VOS does not support automatically mapping overflowed
-floating-point values to +infinity, nor automatically mapping
-underflowed floating-point values to -infinity, unlike many
-other platforms.  The Perl pack function has been modified to
-perform such mapping in software on VOS.  Performing other
-floating-point computations that underflow or overflow will
-probably result in SIGFPE.  Don't push your luck.
-
 =head1 TEST STATUS
 
-When Perl is built using the native build process on VOS Release
-14.5.0 and GNU C++/GNU Tools 2.0.1, all attempted tests either
-pass or result in TODO (ignored) failures.
+A number of the perl self-tests fails for various reasons; generally
+these are minor and due to subtle differences between common
+POSIX-based environments and the OpenVOS POSIX environment.  Ensure
+that you conduct sufficient testing of your code to guarantee that it
+works properly in the OpenVOS environment.
 
 =head1 SUPPORT STATUS
 
@@ -126,10 +106,9 @@ can't guarantee I'll be able to answer them.  There are some
 excellent books available on the Perl language; consult a book
 seller.
 
-If you want a supported version of perl for VOS, purchase the VOS
-GNU C++ and GNU Tools Release 2.0.1 product from Stratus
-Technologies, along with a support contract (or from anyone else
-who will sell you support).
+If you want a supported version of perl for OpenVOS, purchase the
+OpenVOS GNU Tools product from Stratus Technologies, along with a
+support contract (or from anyone else who will sell you support).
 
 =head1 AUTHOR
 
@@ -137,6 +116,6 @@ Paul Green (Paul.Green@stratus.com)
 
 =head1 LAST UPDATE
 
-August 12, 2002
+February 28, 2013
 
 =cut