This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
[patch@31706]01_module_load_conditional.t fix for VMS
[perl5.git] / lib / Module / Load / Conditional / t / 01_Module_Load_Conditional.t
1 ### Module::Load::Conditional test suite ###
2 BEGIN { 
3     if( $ENV{PERL_CORE} ) {
4         chdir '../lib/Module/Load/Conditional' 
5             if -d '../lib/Module/Load/Conditional';
6         unshift @INC, '../../../..';
7     
8         ### fix perl location too
9         $^X = '../../../../../t/' . $^X;
10     }
11
12
13 BEGIN { chdir 't' if -d 't' }
14
15 use strict;
16 use lib qw[../lib to_load];
17 use File::Spec ();
18
19 use Test::More tests => 23;
20
21 ### case 1 ###
22 use_ok( 'Module::Load::Conditional' );
23
24 ### stupid stupid warnings ###
25 {   $Module::Load::Conditional::VERBOSE =   
26     $Module::Load::Conditional::VERBOSE = 0;
27
28     *can_load       = *Module::Load::Conditional::can_load
29                     = *Module::Load::Conditional::can_load;
30     *check_install  = *Module::Load::Conditional::check_install
31                     = *Module::Load::Conditional::check_install;
32     *requires       = *Module::Load::Conditional::requires
33                     = *Module::Load::Conditional::requires;
34 }
35
36 {
37     my $rv = check_install(
38                         module  => 'Module::Load::Conditional',
39                         version => $Module::Load::Conditional::VERSION,
40                 );
41
42     ok( $rv->{uptodate},    q[Verify self] );
43     ok( $rv->{version} == $Module::Load::Conditional::VERSION,  
44                             q[  Found proper version] );
45
46     # This test is expecting the file to in UNIX format, so force
47     $rv->{file} = VMS::Filespec::unixify($rv->{file}) if $^O eq 'VMS';
48
49     # break up the specification
50     my @rv_path;
51     if ($^O eq 'VMS') {
52         # Use the UNIX specific method, as the VMS one currently
53         # converts the file spec back to VMS format.
54         @rv_path = File::Spec::Unix->splitpath($rv->{file});
55     } else {
56         @rv_path = File::Spec->splitpath($rv->{file});
57     }
58
59     # First element could be blank for some system types like VMS
60     shift @rv_path if $rv_path[0] eq '';
61
62     ok( $INC{'Module/Load/Conditional.pm'} eq
63         File::Spec::Unix->catfile(@rv_path),
64                             q[  Found proper file]
65     );
66
67 }
68
69 {
70     my $rv = check_install(
71                         module  => 'Module::Load::Conditional',
72                         version => $Module::Load::Conditional::VERSION + 1,
73                 );
74
75     ok( !$rv->{uptodate} && $rv->{version} && $rv->{file},
76         q[Verify out of date module]
77     );
78 }
79
80 {
81     my $rv = check_install( module  => 'Module::Load::Conditional' );
82
83     ok( $rv->{uptodate} && $rv->{version} && $rv->{file},
84         q[Verify any module]
85     );
86 }
87
88 {
89     my $rv = check_install( module  => 'Module::Does::Not::Exist' );
90
91     ok( !$rv->{uptodate} && !$rv->{version} && !$rv->{file},
92         q[Verify non-existant module]
93     );
94
95 }
96
97 ### test finding a version of a module that mentions $VERSION in pod
98 {   my $rv = check_install( module => 'InPod' );
99     ok( $rv,                        'Testing $VERSION in POD' );
100     ok( $rv->{version},             "   Version found" );
101     is( $rv->{version}, 2,          "   Version is correct" );
102 }
103
104 ### test $FIND_VERSION
105 {   local $Module::Load::Conditional::FIND_VERSION = 0;
106     local $Module::Load::Conditional::FIND_VERSION = 0;
107     
108     my $rv = check_install( module  => 'Module::Load::Conditional' );
109
110     ok( $rv,                        'Testing $FIND_VERSION' );
111     is( $rv->{version}, undef,      "   No version info returned" );
112     ok( $rv->{uptodate},            "   Module marked as uptodate" );
113 }    
114
115 ### test 'can_load' ###
116
117 {
118     my $use_list = { 'LoadIt' => 1 };
119     my $bool = can_load( modules => $use_list );
120
121     ok( $bool, q[Load simple module] );
122 }
123
124 {
125     my $use_list = { 'Commented' => 2 };
126     my $bool = can_load( modules => $use_list );
127
128     ok( $bool, q[Load module with a second, commented-out $VERSION] );
129 }
130
131 {
132     my $use_list = { 'Must::Be::Loaded' => 1 };
133     my $bool = can_load( modules => $use_list );
134
135     ok( !$bool, q[Detect out of date module] );
136 }
137
138 {
139     delete $INC{'LoadIt.pm'};
140     delete $INC{'Must/Be/Loaded.pm'};
141
142     my $use_list = { 'LoadIt' => 1, 'Must::Be::Loaded' => 1 };
143     my $bool = can_load( modules => $use_list );
144
145     ok( !$INC{'LoadIt.pm'} && !$INC{'Must/Be/Loaded.pm'},
146         q[Do not load if one prerequisite fails]
147     );
148 }
149
150
151 ### test 'requires' ###
152 SKIP:{
153     skip "Depends on \$^X, which doesn't work well when testing the Perl core", 
154         1 if $ENV{PERL_CORE};
155
156     my %list = map { $_ => 1 } requires('Carp');
157     
158     my $flag;
159     $flag++ unless delete $list{'Exporter'};
160
161     ok( !$flag, q[Detecting requirements] );
162 }
163
164 ### test using the %INC lookup for check_install
165 {   local $Module::Load::Conditional::CHECK_INC_HASH = 1;
166     local $Module::Load::Conditional::CHECK_INC_HASH = 1;
167     
168     {   package A::B::C::D; 
169         $A::B::C::D::VERSION = $$; 
170         $INC{'A/B/C/D.pm'}   = $$.$$;
171         $INC{'[.A.B.C]D.pm'} = $$.$$ if $^O eq 'VMS';
172     }
173     
174     my $href = check_install( module => 'A::B::C::D', version => 0 );
175
176     ok( $href,                  'Found package in %INC' );
177     is( $href->{'file'}, $$.$$, '   Found correct file' );
178     is( $href->{'version'}, $$, '   Found correct version' );
179     ok( $href->{'uptodate'},    '   Marked as uptodate' );
180     ok( can_load( modules => { 'A::B::C::D' => 0 } ),
181                                 '   can_load successful' );
182 }
183